Notepad++ 6.7.9.2 does not focus when I open a file



  • This is a brand new problem that has just started within the last few days. I have Notepad++ open all the time as I’m always referring to text files and/or creating new ones. Whenever I navigate to a directory and double click a text file, it always opens up and my operating system (Windows 7) brings focus to Notepad++

    For whatever reason, it’s now just opening the file but Notepad++ is not getting focus. I’m wondering if I might have mistakenly pressed some ALT+CTRL+ key combo that disabled focus? I have looked around in Settings -> Preferences but have not found any such option. This problem only happens with Notepad++. My other programs behave as usual, but I’m sure it’s still possible that it’s not a problem with my Notepad++ settings, but I thought I’d start looking there first.

    In summary, does anyone know of a setting in Notepad++ that would cause it to remain minimized when opening a new file?



  • Hi David,

    I’m not sure, but is there any relation with the option Setting - Preferences - MISC - Minimize to system tray ?

    Cheers,

    guy038



  • Thanks for the reply. There is a weird relation there it would seem. If I check that checkbox, then minimizing Notepad++ puts it into the system tray instead of the task bar. However, when I open a file from the file explorer with it in the sys tray, it brings Notepad++ to the forefront as I was use to. I was hoping checking and unchecking that would essentially reset something and fix the problem, but it didn’t. Once I unchecked it, minimizing puts Notepad++ back in the taskbar like usual, but then opening a file leaves it in the background. Thanks for the thought. I’ll keep digging. Maybe an uninstall/reinstall will fix it. (While also wiping out %appdata%/Roaming/Notepad++ )


Log in to reply