i see unknown symbols



  • Latest notepad++, sometime i see unknown symbols while edit big text file! (~5MB)



  • It can fixed in new version???

    Screenshot



  • Easy: you need to unselect View > Show Symbol > Show End of Line.

    FYI: CR = Carriage Return (ASCII:13), LF = Line Feed (ASCII:10). Windows text files use CR+LF as the end-of-line (EOL) sequence. Unix/Linux uses just LF for EOL. Ancient Macs used just CR.

    EDIT: Though I’m not sure why it started midway through. Also, it looks like you have mixed line endings (see the first red circle, with just LF). Might want to use Edit > EOL Conversion a couple times, to go to Unix and back to Windows, and see if that clears it up.



  • Having the carriage returns show up mid-file normally indicates the underlying buffer got corrupted. This mostly happens when the periodic backups is turned on for large files. This has been a known issue for years (which is why I never use it).



  • How to fix it ?



  • Looking at @dail 's comment you need to switch off the periodic backups (Settings->Preferences->Backup).



  • Thanks for the heads-up @dail
    This happened to me too, just now. Perhaps related to having too many files tabbed open. Another artifact was after the first CRLF the first character of each line disappeared. I copy/pasted the file and all the text was there, minus the CRLFs.

    Take precautions, act like the file may be corrupt or on the verge of corruption before you do anything else. However, with that in mind, after I closed a couple of files the subject document became the active document and I did a simple ctrl-S and the initial chars reappeared, and the CRLF flags disappeared. YMMV

    The periodic backups are one of the reasons I like Notepad++ so much. Forewarned is forearmed, much obliged.


Log in to reply