Every since last patch, extreme slowness and Not Responding...



  • Every since the last patch, Notepad++ is extremely slow to close a file (like half a minute) and the CPU maxes out. I frequently get (Not Responding) when trying to shut it down, too.



  • @Shane-Hebert

    would you mind to share your config/version? (? menu -> debug-info)
    Are those local or remote files?

    Cheers
    Claudia



  • Notepad++ v7.5.3 (32-bit)
    Build time : Dec 5 2017 - 10:45:46
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : ComparePlugin.dll DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll PluginManager.dll

    Temporary files mostly. I frequently load up Notepad++ to copy-and-paste text into a new file (“new 1”, “new 2”, etc.) to save for copy-and-paste elsewhere (never more than about 500KB of text, most often around 100KB). When I’m done with the text, I’ll close the file and not save it. Clicking the close button (the X for the file in the upper right, not the app close button) for the file will cause NotePad++ to “hang” for as long as 20 to 30 seconds but usually 5 to 10 seconds and then I get the “do you want to save dialog”. If I have the temp file open and close Notepad++ completely (the app exit button on the upper right), the whole app goes gray and it will show a “not responding” message in the title. After some time (again, 20s or more) it will ask me if I want to save the file. Once I had Notepad++ crash when in the “not responding” state but I didn’t capture the information about the crash. I thought it was just a fluke at the time. If it happens again, I’ll save it.

    Since then, I also checked to make sure the plugin manager was up to date as well as all the plugins being up to date. The ones I have loaded (according to the Plugin Manager Installed tab) are:
    Compare (2.0), Converter (4.2.1), DSpellCheck (1.3.5), MIME Tools (2.1), NppExport (0.2.8), NppFTP (0.27.3), Plugin Manager (1.4.9). All have “good” for stability.

    It seems to be related to file size. I created a temp file of 10 characters just now (just the ‘a’ character 10 times) and the app closed quickly. I restarted Notepad++ and pressed ‘a’ 10 times, copied those 10 characters to make 100, then used that to copy enough to get 1000 characters, and then those 1000 characters to get about 173000 characters (holding down control-V with the 1000 characters on the clipboard). After I release control-V, the app is now “not responding” (has that in the title) for about 10 seconds. Eventually, that goes away and the app is responding. Now I clicked the app close X and its hung for almost 20 seconds before the dialog to save popped up. I told it to not save but exit anyway and the dialog went away, but again about 20 seconds before the app actually closed and went away.



  • @Shane-Hebert

    thank you for such detailed report, yery much appreciated.

    First, I would upgrade to 7.5.4 as it solves an issue with plugin notifications,
    with could even lead to crash npp, maybe this is what you encountered.

    I tried to reproduce, with version 7.5.3, what you have experienced but wasn’t successful.
    I don’t have that issue.

    If you don’t want to update right now, would you mind to retest without plugins enabled?

    stop npp
    rename the plugin directory with install directory
    start npp (now you should see that you don’t have a plugin menu anymore, if you still have,
    rename the plugin directory under %APPDATA%(Roaming directory or not)\notepad++ directory)
    and redo the test?

    Cheers
    Claudia



  • I exited Notepad++, renamed the plugins directory to plugins.old, restarted notepad++ and ran the same scenario described above… same thing happened, exactly as described for it before. But I noticed I have a “Plugins” menu. So I went to %appdata% and renamed the plugins directory there. Reran notepad++ and reran my test. It doesn’t show that issue anymore… exiting out at the end was as quick as it should be. So, to figure out which one it was… it seems both. I went back to the install directory and renamed plugins.old back to plugins and reran my test case and it behaved badly again (as described above).

    Should I delete the two plugins directories and let a new install recreate them or something?



  • @Shane-Hebert

    Thank you for doing the test.

    So now we know that the problem is with one of the plugins
    or with the communication (notifications) with the plugins.
    I assume the later and would propose updating npp.

    If it is plugin related and you are still interested
    which of the plugins is the problematic one you could
    start enabling one after the other until the issue reoccurs.

    The reason why both directories are used, is that during the installation
    the check, to the question whether plugins also loaded from %APPDATA%
    should be allowed, was set.

    If you do a new install I would rename the plugin directory,
    just in case you have special plugin configurations you do not want to loose.
    And you need to be prepared that plugin manager is not part of the npp installation anymore,
    you need to install it manually from here.

    Cheers
    Claudia



  • One other thing I just noticed… in the Plugin Manager screen in the Installed tab, none of the plugins have the box on the left checked (and haven’t been checked for any of this). Does that mean that none of the plugins are actually active?



  • @Shane-Hebert

    no, the check is used to identify which one should be removed or reinstalled.

    Cheers
    Claudia



  • Very odd… I didn’t have any real custom configuration or anything with notepad++ and I was running the 32-bit version so I uninstalled notepad++ (32-bit version) and downloaded the 64-bit version (7.5.4) and am having the exact same issue as before (running the same scenario, the same thing happens).



  • @Shane-Hebert

    Strange, indeed, a shot in the dark

    Plugins->DSpellCheck->disable Spell Check Document Automatically

    Cheers
    Claudia



  • With the new install, I had it restore previous session and the backup thing every 7 seconds (the default settings, which I normally disable) and it would do the Not Responding when I started notepad++ (just another data point). So I disabled the spell check as you suggest and the problem goes away… now it’s fast at everything… so that seems to be the culprit… I kind of like having automatic spell check, though… is there something I can check to see what’s causing the problem and maybe fix that? It wasn’t a problem before 7.5.3… was some issue introduced maybe?



  • Satrting with npp 7.5.2 DSpellCheck Plugin has been included so it might be
    that your previous npp did have a different version of the plugin installed
    and maybe the newer version does have an issue under some special configuration.

    A general issue doesn’t seem to be the case otherwise I should have discovered the
    same behavior when testing it and I use the same version as you do, 1.3.5.

    I guess it would best if you report this to @Predelnik (author of DSpellCheck plugin) per github issue

    Cheers
    Claudia


Log in to reply