Theme resets after switching to administrator mode



  • I’m running Notepad++ on Windows 10, and occasionally have to switch over to running in administrator mode to save system files. I usually do this by editing a file, clicking save and then answering the prompt “do you want to launch notepad++ in administrator mode?” with a yes. Since the latest update the newly opened notepad++ has forgotten my theme selection, and my global style overrides. Closing & reloading doesn’t help - I have to select my preferred options again.

    Is this a bug? Or am I missing an option somewhere?



  • @Henry-Burrows

    would you mind sharing your debug-info? (available in ? menu)

    Cheers
    Claudia



  • Here it is:

    Notepad++ v7.5.4 (32-bit)
    Build time : Jan 1 2018 - 01:47:45
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll JSMinNPP.dll mimeTools.dll NppConverter.dll NppExport.dll NppFTP.dll PluginManager.dll

    By the way - I also discovered other preferences had been reset too, not just styles.



  • @Henry-Burrows

    this doesn’t seem to be a general problem.

    so there seem to be something specific about your setup.
    What you could try out is what happens if you use one of the portable, zipped npp versions.
    Just download, extract to where ever you want, run npp and retest.
    If it is behaving the same, then it seems to be system specific if it isn’t then it looks more like
    application configuration specific.

    Cheers
    Claudia



  • Thanks for the suggestion - it does seem to be something specific about my setup then, as the portable one doesn’t exhibit the same behaviour, it works as it should.

    I’ll probably try another re-install and reboot and see if that sorts it. Thanks!



  • @Henry-Burrows

    what you could try first, without installing, is to rename the
    %APPDATA%\Roaming\Notepad++ directory and let it recreate on npp start

    Cheers
    Claudia



  • Sorry, didn’t see your reply in time; however, a re-install and reboot has resolved the issue.

    Thanks again!


Log in to reply