how to link to my URL



  • Notepad++ v7.5.4 (64-bit)
    Build time : Jan 1 2018 - 01:50:29
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll



  • @Joel-Snyder

    1. Stop notepad++

    2. Download this zip https://github.com/bruderstein/nppPluginManager/releases/download/v1.4.9/PluginManager_v1.4.9_x64.zip
      and extract the content into the directory C:\Program Files\Notepad++
      If it asks whether you want to overwrite plugin directory say yes.

    3. Open windows explorer and goto %APPDATA%\notepad++\plugins\config directory
      (note, it might be that the directory is %APPDATA%\roaming\notepad++\plugins\config)
      Check if there is a directory called NppFTP
      If so, back it up to a save place - it might contain the configuration and credentials from your ftp server setup.

    4. Start notepad++ and go to Plugins->Plugin Manager->Show Plugin Manager

    5. From the list of available plugins check NppFTP and press Install

    6. Follow the instructions.

    7. Restart notepad++ and check if you can connect to your ftp server.

    If everything is ok - done.
    If you can’t connect, try to replace the newly created files with the files backed up in step 3.
    If this still doesn’t work then I assume you need help from your web person to get the setup done.

    Cheers
    Claudia



  • @Claudia-Frank said:

    %APPDATA%\roaming\notepad++\plugins\config

    Hi Claudia–

    Still having difficulty – when I click PlugIns (after closing and re-opening Notepad++), I don’t have a choice for Plugin Manager – All I get is:

    Converter
    DSpellCheck
    MIME tools

    I’m totally flummoxed … and confused, even. You’ve been great and I understand if you don’t want to fuss with this any longer – but I thought I’d inform you of this most recent roadblock. Let me know if you have any other suggestions. Thanks much!



  • Hello Joel,

    if you don’t see the plugin manager then I have to assume that step 2 failed.
    After you downloaded the zip, how did you proceed?

    Cheers
    Claudia



  • @Claudia-Frank said:

    %APPDATA%\roaming\notepad++\plugins\config

    Hi Claudia–

    I downloaded the zip file to the C:\Program Files\Notepad++ directory. So far so good. BUT I get hung-up on Step 3–I can’t find either of the %APPDATA directories you cite. Neither can I find an NppFTP directory. And, as I mentioned, I do have the downloaded PluginManager but I just can’t seem to access it within notepad++ (see my last note/plea).



  • Hi Joel,

    let’s try to sort out plugin manager issue first.
    When you open the explorer and goto C:\Program Files\Notepad++\plugins,
    do you see a pluginmanager.dll ?

    Cheers
    Claudia



  • Yes - I also, somehow, have two folders labeled C:\Program Files\Notepad++\PluginManager_v1.4.9_x64 - each has a plugins folder.



  • You can delete the two folders named PluginManager_v1… they are not needed/used,
    but I wonder how you unzipped this file that it has created these folders. (??)

    You are still using Notepad++ v7.5.4 (64-bit) - you didn’t install the 32bit in the meantime, didn’t you?

    How big is the file C:\Program Files\Notepad++\plugins\PluginManager.dll ?

    Cheers
    Claudia



  • Deleted those two folders–and no, I didn’t install the 32 bit Notepad++.

    The C:\Program Files\Notepad++\plugins\PluginManager.dll file is only 505 kb.



  • Looks ok - the zip states it is 516608 bytes.
    Didn’t you get any info that notepad++ was not able to load a dll when you start npp?
    It is in the right directory, is a dll … should work or complain if it can’t be loaded.

    Cheers
    Claudia



  • No–received no info re inability to load a dll when starting Notepad++ … so I guess I’m at a dead end until my webmistress comes back. Don’t even know to whom I can contact/complain to at Notepad++.



  • Sorry, currently I’m running out of ideas, not sure what we are missing here - don’t like such situation.
    Maybe a good sleep will reveal the hidden secrets - already 2 o’clock in the morning - good night.

    Cheers
    Claudia



  • Many thanks to Claudia for her assistance–but I still haven’t been able to link Notepad++ with my website. I used to be able to see in Notepad++ a button that enabled connection to the net.

    Any others have some thoughts?



  • The “other thoughts” are that you still have not successfully installed the plugin manager, let alone the NppFTP plugin. Until you are able to do that, you will not have the button.

    Your difficulty in installing the plugin manager says something has gone wrong (the instructions weren’t clear, or you have some other config item that hasn’t been mentioned)

    Your ? > Debug Info claims you have installed 64bit Notepad++ in C:\Program Files\Notepad++\notepad++.exe. After you opened your downloaded PluginManager 1.4.9 x64 zipfile, you should have extracted the contents into C:\Program Files\Notepad++\. After ensuring you’ve done that, please close Notepad++, then open it again (making sure it re-reads the list of plugin DLLs) and give us the ? > Debug Info again.

    Next, open up a cmd.exe window (type the Win+R, then cmd.exe), and run

    dir /s "c:\program files\notepad++"
    dir /s "%APPDATA%\Notepad++"
    

    and copy and paste the full results into here (as shown below in pasting data).

    Note that it will give us the complete contents of your Notepad++ executable directory structure and your Notepad++ AppData structure. If you have any sensitive filenames listed there (or if you wish to hide your windows user name) , just xxxx them out before pasting in the forum.


    Please note: some people get confused between %APPDATA%\Notepad++ and %APPDATA%\roaming\Notepad++. On all modern Windows configurations (everything Since Win7, and probably since Vista), %APPDATA% exapands to c:\users\name.here\AppData\Roaming (or similar, depending on your system). And on versions before then, there was no ...\user.name\AppData\Roaming, so you should still use %APPDATA%\Notepad++.

    So unless I’m very much mistaken, if you were really looking for %APPDATA%\Roaming\Notepad++, as you quoted from Claudia’s post, you wouldn’t find it. If you really meant you looked in ...\username\AppData\Roaming\Notepad++, then that would be the right location for your Win10 system.


    pasting data

    format them like this

    in the forum. Or alternately, indent every line by 4 spaces

        first line
        second line
    

    so it will render like

    first line
    second line
    

    in the forum. Or, if you don’t want to manually indent (which is easy enough if you’re editing your post in Notepad++ to begin with), you can do the more simple

    ```z
    contents here
    ```
    

    so that it will render like

    contents here
    


  • Peter–

    Thank you for your response. I’ve tried to follow your instructions – I still don’t have “the button” upon reopening Notepad++ but, as you asked, I’ve pasted in the data you specified … let me know if this enables you to help me further. I appreciate it! (I have not posted the full results from "dir /s “c:\program files\notepad++”
    dir /s “%APPDATA%\Notepad++”
    as this forum limits the number of characters one can post).

    Notepad++ v7.5.4 (64-bit)
    Build time : Jan 1 2018 - 01:50:29
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll PluginManager.dll



  • You could do a screenshot, upload the picture to imgur or similar service, and embed the image as ![](https://path/to/image.png), which would show the picture directly in the forum.

    However, your ? > Debug Info now shows you have the PluginManager available, which is a good first step (or, per Claudia’s list, second step 😉).

    Let’s try step 3: in your cmd.exe window, run cd "%AppData%\Notepad++", then dir . to see a directory listing of your NPP user-config. You don’t need to share this listing unless you don’t see the plugins subdirectory listed. If you do see it listed, from the same window (so you’re still in that directory), list dir .\plugins. You should see a config subdirectory; if not, show us, otherwise, dir .\plugins\config. On this one, you may or may not see an NppFTP subdirectory. If you do, per Claudia’s #3, make a backup of it (cd .\plugins\config then ren NppFTP NppFTP.bak); if you don’t have the %APPDATA%\Notepad++\plugins\config\NppFTP directory, that’s tolerable for now.

    Back in Notepad++, run Plugins > Plugin Manager > Show Plugin Manager. Search through the Available tab for NppFTP. Check the checkbox, and click Install. There will be a progress bar, and then it will either restart Notepad++ or ask you for permission to do so. When Notepad++ is reloaded, you should see the NppFTP icon on your toolbar, and Plugins > NppFTP > ... should be in your menus. If this worked, you’ve now made it halfway through the 7th step. Yay! ☺

    If you cannot find it ☹, please show us your updated ? > Debug Info. Since there’s not enough room for the full dir /s, instead please

    cd "\Program Files\Notepad++\"
    dir   .   .\plugins
    

    which will at least show us the main executable directory and its plugins subdirectory, so it will give us a clue as to how to help you next.

    At this point, I’m going to ask you to take a detour. Load up some other FTP software (FileZilla is my recommendation, but whatever you usually use), and make sure you know how to connect to your website’s FTP or SFTP server. Prove that you can connect to the server in this way. If you cannot, you will need to get the correct information from your web person (and that individual is more likely to have done it through a standard FTP client rather than thru Notepad++, which is why I suggested using a standalone client at this point). Once you know the FTP-client settings to connect to your host, and have proven you can do it, you can move back to Notepad++ and NppFTP:

    If you do have NppFTP available in Notepad++, you should be able to show NppFTP window at this point. Click on the Settings “Gear” icon, and select Profile Settings. Since at this point, you presumably don’t have a previous config, you will have to create a new one. Use the FTP setting from my detour. If you aren’t sure how all of those settings translate from the standalone FTP client to the the NppFTP connection setup, give us some screenshots of the working FTP config info (you can paint over sensitive usernames and servernames, but leave as much info as possible), and we can probably help you translate.

    I know there are a lot of things in this post. But I’m trying to give you enough detail to get through this, and enough reminders of places to provide us with information if something goes wrong. If something doesn’t work, give us as much information as possible. If you cannot fit it all in one post, split it across multiple posts, or embed screenshots, or something. Alt+PrintScreen and mspaint.exe and imgur are your friends. The more relevant information you can give us, the easier it will be for us to continue to help you.



  • IT WORKED!! I’M IN!!
    Wow – my webmistress will be so proud of me for accomplishing this “myself” (with just a little help from Claudia and Peter! ;-) )
    Thank you, guys–you’ve been great … and very patient.
    If you have any interest in “audio description”, feel free to check out www.audiodescribe.com or www.acb.org/adp
    Thanks again!



  • Hello, @joel-snyder and All,

    I did not intervene, until then, in your discussion, because I don’t use NppFTP plugin, at this moment. But, out of curiosity, I visited your website :

    www.audiodescribe.com

    And, I must say, that being deaf of one ear, since my birth, and having an hearing aid, for the other ear, since the age of 30 about, I fully understand the difficulties that the blind and the visually impaired people have to cope, with an handicap far higher than mine !

    So, keep on applying your valuable method, which brings them, I am convinced, an inestimable comfort of life :-))

    Best Regards,

    guy038



  • Thanks so much, Guy –


Log in to reply