Plugin manager missing on Notepad++ x86



  • I installed the x64 version of Notepad++ via on my laptop running Windows 10 Enterprise 15063.250 with

    choco install notepadplusplus.install

    I then realized that I didn’t have plugin manager in the x64 version of Notepad++ so I uninstalled it with the chocolatey gui and installed the 32 bit version of notepad++ via chocolatey on my laptop running Windows 10 Enterprise 15063.250 with

    choco install --x86 notepadplusplus.install

    I then still didn’t have Plugin manager so, I I then uninstalled it using the chocolatey gui, but when I typed which notepad++ (which is an alias for get-command $args -All | Format-Table Definition) at a PowerShell prompt it was showing as available from:

    C:\ProgramData\chocolatey\bin\notepad++.exe
    C:\Program Files (x86)\Notepad++\notepad++.exe

    I deleted C:\ProgramData\chocolatey\bin\notepad++.exe and that got rid of one of the entries returned by which , but which at a PowerShell prompt still said it was at C:\Program Files (x86)\Notepad++\notepad++.exe I then manually uninstalled it using Add Remove programs. Now, when I type which notepad++ I still see:

    C:\Program Files (x86)\Notepad++\notepad++.exe

    but C:\Program Files (x86)\Notepad++ no longer exists . In a DOS prompt I did a

    set > c:\set.txt

    and opened set.txt with a text editor but “notepad++” isn’t in my path or anywhere else in my environment. I guess it’s somewhere in the registry?

    In Powershell I’ve done:
    C:\windows\system32> get-command notepad++ -all

    CommandType Name Version Source


    Alias notepad++ -> C:\Program Files (x86)\Notepad++\n…

    C:\windows\system32> remove-item alias:notepad++
    The alias for notepad++ goes away but returns if I restart PowerShell, so it must be in the registry.

    I’ve manually downloaded the and installed x86 version of Notepad++ from the Notepad++ website, but I still don’t have Plugin manager. Any idea how to fix this?



  • @Eric-Goforth

    see this FAQ.

    Cheers
    Claudia


Log in to reply