File Explorer / Highlight 3 files to open at once / Press Enter, Computer Seizes



  • File Explorer / Highlight 3 files to open at once / Press Enter, Computer Seizes

    NP++ and Plugins are all updated:

    Notepad++ v7.5.6 (32-bit)
    Build time : Mar 19 2018 - 00:26:59
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : CustomizeToolbar.dll DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll NppTextFX.dll PluginManager.dll SpellChecker.dll

    If I do Ctrl+Alt+Delete soon enough, I can get to the screen with options (like the Task Manager), and do a Restart from there.

    If I let it sit for a minute or so, it does weird things to the icons on my Taskbar, and can only be shut down by powering it off.

    NP++ can be open, with a text file showing, and then I highlight two others to open, and it’s fine . . . but, 3 text files at once, or 4, and I’m frozen.



  • @Jorge-Jorhoe

    does this happens as well if the files are stored under let’s say C:\ or D:\ directly?
    Are those network attached files?

    Cheers
    Claudia



  • If I put three text files on C: and try to open them, the computer freezes . . . If I only open two at one time, it works as you expect

    It’s not a networked file, it’s my desktop computer

    No “warnings” or “critical” in the Event Viewer, just “Information” that seems to show no major errors.



  • @Jorge-Jorhoe

    could you try the same without plugins used by temporarily renaming the plugin folder?
    And does this also happen if you use the open file dialog from notepad++?
    Meaning, run notepad++, use menu file->open and select the three files in the dialog ?

    Cheers
    Claudia



  • @Jorge-Jorhoe you should also try the portable version ( zip version) : https://notepad-plus-plus.org/repository/7.x/7.5.6/npp.7.5.6.bin.zip )



  • @Jorge-Jorhoe said:

    File Explorer / Highlight 3 files to open at once / Press Enter,

    @cmeriaux said:

    try the portable version ( zip version)

    The way I read the OP’s description of the problem, the OP has Notepad++ installed and has file associations set to run the installed Notepad++. Thus I’m not sure how, even if the original Notepad++ is uninstalled, that the portable version helps with this problem?



  • I narrowed down. I’m running the latest version of Dexpot, 1.6.14.2439 . . . The settings I changed, and my notes, are below.

    Here’s what happens:

    If NPP is open with one text file showing, you can go to File Explorer, and open 2, 3, 4 more, all at the same time, probably even more.

    If NPP is closed, however . . . You can open 1 or 2 at the same time . . . but if you try to open 3 or more at the same time, the computer has a seizure.

    There are a lot of settings in Dexpot. Could there be a setting that addresses this?


    Dexpot | Virtual desktops for Windows . . . https://www.dexpot.de/?lang=en


    Settings / General / Variable desktops / Number of desktops . . . 3
    . . . If you have 4, and have a text file on each of them . . . you close two Desktops,
    . . . so what happens to those text files? They’re located in:
    . . . C:\Users\UserName\Desktop
    . . . C:\Users\UserName\Desktop 2
    . . . C:\Users\UserName\Desktop 3
    . . . C:\Users\UserName\Desktop 4

    Settings / General / Variable desktops / Initial desktop [1]

    Settings / General / Start / [check] Start with Windows
    Settings / General / Start / [check] Hide splash screen

    Settings / Components / Desktop Manager / Options / [check] Start with Dexpot
    . . . By default, you can drag this around, it’s not fixed in the lower right
    . . . Move it up 3"
    . . . Keep it un-checked, though, I don’t need to see it
    . . . Access the other Desktops by right-clicking the icon in the Notificaiton Area

    Settings / Components / Desktop Manager / Orientation / it can go Vertical

    Settings / Switching Desktops / Desktop elements
    . . . Desktop icons / [check] Customize desktop icons
    . . . Background / [check] Customize desktop background
    . . . Background / [check] Apply manual changes to Dexpot configuration

    . . . Taskbar / [un-check] Keep all taskbar elements visible (so it’s not “Always on top”) . . . NO, THE TASKBAR IS DIFFERENT FROM THE DESKTOP MANAGER “FLOATING BAR,” THIS SETTING DOES NOT APPLY

    Then, go ahead and change the background colors of the other Desktops:
    right-click Desktop / Personalize / Background
    Themes / Save theme . . . otherwise, it might start you with a random color from before


    DON’T NEED THIS, IF DESKTOP MANAGER IS STARTED WITH THE PROGRAM

    Settings / Switching Desktops / Desktop names / Show the desktop name [permanently]
    . . . Position / Custom (draggable) / Right
    . . . Text / %g . . . (just the number)




  • If I make MS Notepad my default text editor,

    with Dexpot running,

    and I open 5 text files at once,

    it opens them with no problem . . . 5 separate text windows open


Log in to reply