One annoying bug with ANSI encoding



  • Frequently I’m using Notepad++ for parsing file dumps when binary file converted to text representation like

    1600C0 00 01 00 06 94 4D D0 D3 CA 00 00 00 01 00 06 20 | …M…
    1600D0 9D 8C D6 CB 00 00 00 01 00 06 BA 5C E1 D8 CC 00 | …
    1600E0 00 00 01 00 06 BE 61 60 DB CD 00 00 00 01 00 06 | …a`…
    1600F0 C1 AA E3 DD CE 00 00 00 01 00 06 7B 35 0A E1 CF | …{5…

    and stored as ANSI file (8 bits per character). When parsing internals I moving blocks of text (Enter), making comments etc like

    160060 06
    00 00 00 60 <- id(key) NULL
    74 00 00 00 01 00 <- page-file

    06 03 00 00 00 | …`t…
    160070 B1 00 00 00 01 00

    06
    95 01 47 C2 <- -1035533931 (C2470195) id(key)
    B6 00 00 00 01 00 <- page-file

    For many years I wanted to report bug when during editing whole text below suddenly broke with some symbols (somewhere in the middle of 10-25 MB size file, Undo doesn’t helps, all editing after save lost), but due to sizes and unpredictable behavior of bug it was hard to reproduce. Encoding in settings always set to “Encode in ANSI”, but Notepad++ acts like it trying to read UTF-8 file. Today by mistake I tried to open ordinal binary file (not converted to text) and got what frequently happens to ANSI text files during editing - it was all full of special symbols despite encoding was set to “Encode in ANSI”.

    Screenshot https://ibb.co/guVKm8
    I uploaded zipped file on Google drive https://drive.google.com/open?id=1EJMOQk72wM_3PiDOfXLPKz5oST2-7fnb



  • @Vladimir-Olegovich said:

    report bug when during editing whole text below suddenly broke with some symbols

    This is sort of a known issue. I believe it relates to your Backup setting (turn backups off and it should no longer occur)…although @dail is sort of a known expert on this issue and can probably provide more details.

    by mistake I tried to open ordinal binary file (not converted to text) and got what frequently happens to ANSI text files during editing - it was all full of special symbols

    “full of special symbols”…yes this is what I would expect if you open a binary file in Notepad++



  • Binary file was bad example (how file looks when bug occurs), but sometimes it happens to my txt files, even on selecting part of text with mouse. I’ll try with turned off “Enable session snapshot”, except bug is unpredictable, sometime after updates or changing settings to ANSI as default encoding I thought it fixed. And then it happens again when I made lot of changes and forgot to save before error.


Log in to reply