Notepad ++ Shutdown is EXTREMELY slow when Folder is open as workspace



  • I really like Notepad++ and would like to continue to use it, however, this is an issue that definitely needs to be fixed. The problem is that Notepad++ sometimes takes a fairly long time to load (not the worst of the behavior), but more significantly, on closing Notepad++, the program causes such a drain on resources that even the mouse pointer becomes sluggish and unresponsive (the pointer will skip and stutter slowly across the screen trying to catch up to wherever I’ve tried to drag it), and this can sometimes go on for several MINUTES unless I can manage to activate task manager and end the Notepad++ process from there.

    The issue is clearly not the PC. I started seeing this trouble when working on an older, slower machine, but I’ve upgraded to running Windows 10 on an AMD Rizen 7 quad core 3.6ghz processor with 16gb of ram, and still see the issue.

    In fact the behavior has been occurring with every 7.5.x version that I’ve had installed, including the latest, and is very repeatable. I have been looking for answers, and found one other issue I thought at first might be related, namely:

    https://notepad-plus-plus.org/community/topic/15028/every-since-last-patch-extreme-slowness-and-not-responding

    However, the “solution” indicated in that thread did nothing for me. I’ve uninstalled and reinstalled Notepad++ without any plugins at all, and it makes no difference. Plugins aren’t the problem.

    What I did finally discover just today, however, is that if I don’t make use of the “Open Folder as Workspace” option, then the problem does not occur. This makes some sense because I use Notepad++ for software development and the projects I’m working on now are Drupal projects with Angular at the front-end, both of which generate a LOT of files in a fairly complex directory structure.

    Curiously enough, the problem doesn’t occur when OPENING the folder as a workspace. At that time, the tree structure pops in quickly, and there are no noticeable performance issues until NP++ is shut down, and again later when it is reopened (though by far the worse behavior occurs on shutdown).

    It turns out that if I open a workspace with a very SMALL tree (few subfolders and files) the program behavior is okay – it opens and closes with no apparent problem. However, the convenience of being able to navigate and open project files directly from within a NP++ workspace window should be obvious, and I’m hoping you can come up with a fix for this fairly soon.

    To replicate the behavior, simply choose “Open folder as workspace” and select a folder with a large number of subfolders and files.

    As to how large is large enough to cause the issue:

    With about a hundred folders and 400 or so files, I saw similar unresponsive behavior shutting down Notepad++ when working on an Angular project in Notepad++ on my older, much slower machine.

    On my current machine, however, I don’t notice the issue with that size folder structure. However, a typical Drupal project can have (insanely) several thousand folders and upward of ten thousand files. The vast majority of them are generated and needn’t ever be edited, but since there is no way to tell Notepad++ to ignore certain subfolders, and files at the root of this structure MUST be edited, there’s no way to open a workspace window in Notepad++ that doesn’t suffer from this behavior.



  • I was having generally very slow response while editing. NPP was taking 25% of the CPU. Yikes! Only 1 file open.

    So I upgraded to 7.5.8 64bit. I installed using the default settings and things were still slow and CPU intensive. I del the complete npp folder and reinstalled with NO PLUGGINS and it’s running fast.

    Win 7 Pro SP1. i5 CPU 8G Ram. SSD

    Apparently my mileage varies.



  • I created an account on this forum just so I could corroborate @Taryn-Vivino 's findings. This problem was driving me NUTS, so much so that I almost gave up on Notepad++. Closing the program brought my PC to a halt for almost 2 min every time. I wish I had thought about “Open Folder as Workspace” before, it would have saved me a lot of headache. Once I removed my big “code” folder from the workspace list, all my problems went away.

    I would love to see a fix for this, I loved the Project Workspace feature a lot. For now I can live without it if it means I can continue to at least use the program itself without other trouble.



  • test test




Log in to reply