Notepad++ 7.5.9 release



  • Hi, @don-ho and All,

    Many thanks for this new version and, also, for the plugin manager, which is about to be launched !

    So, I’m quite sorry, Don, for bothering you, but, indeed, there a problem with the new v7.5.9 version, when using a file, which contains very long lines ( ~1000 chars or over )

    I followed the test method, given by @fox-e and I did obtain the same results as @fox-e and @harold-krueger-iv :-((

    From the site https://www.lipsum.com/ I copied one page, and, with a lot of CTRL+V actions, I got a file of about 38.2 Mb ( > 40,000,000 bytes )

    When the Wrap option is not set, N++'s behaviour is quite correct. But, as soon as the Wrap option is on, the fact of switching from, let’s say, the change.log file to this test file needs about 10 seconds before seeing the file contents !? If you close the file, with Ctrl + W and re-open it with Ctrl + Shift + T, again, the delay is really significant !

    And, if you’re using, like me, the option Remember current session for next lauch and that this test file was the active tab, before closing, any restart of N++ take several seconds, providing that the wrap feature was set ! Just note that, on the contrary, if the active tab was change.log before closing, the restart of Notepad++ is quite correct !

    And , unfortunately, it happens that this delay gets increasing, as the file size increases :-((

    Here is my Debug Info information :

    Notepad++ v7.5.9   (32-bit)
    Build time : Oct 14 2018 - 15:02:52
    Path : D:\@@\759\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows XP (32-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll 
    

    Again, problem occurs ONLY when the Wrap feature is ticked !

    Thanks for your investigation !

    guy038



  • ISSUES ON LAUNCH.

    When launching Notepad++ 7.5.9 on Windows 10, 64 bit system, I get the following in two
    separate dialog boxes:

    1. “Create new file” “C:\Program” doesn’t exist. Create it? YES OR NO buttons.

    2. “Cannot open file” “C:\Program Files\Notepad ++\updater\Files\Notepad++\change.log” cannot be opened:
      Folder “C:\Program Files\Notepad ++\updater\Files\Notepad++” doesn’t exist. OK button.

    Happens EVERY time at program launch.

    FYI.

    jeff



  • @Jeffrey-Jodoin

    IIRC, it sounds like the shortcut you have for running Notepad++ has the change.log file embedded in it?

    Otherwise, try a search on site:https://notepad-plus-plus.org/community/ change.log.

    Or maybe something related to this.



  • @abdelhameedma I read somewhere that this is actually a bug with the DSpellCheck plugin. I uninstalled the plugin and I don’t have that issue anymore.

    I’m not sure how to report this possible bug with the plugin; anyone?



  • @Jeison-Rutz said:

    @abdelhameedma I read somewhere that this is actually a bug with the DSpellCheck plugin. I uninstalled the plugin and I don’t have that issue anymore.

    I’m not sure how to report this possible bug with the plugin; anyone?

    @donho hello, and first of all, thanks for all the hard work.
    For the issue “vector<T> too long” above, and for some other issues people mentioned about “long time for opening or switching open files tabs”: I was having all these issues until I uninstalled the DSpellCheck plugin. Now it works as fast as expected.
    I have 64bit version of NPP on Windows 10, and I have and use XML Tools plugin quite often without any issues after I uninstalled DSpellCheck.

    I hope this info helps.



  • I’m also having issue with vector <T> too long error
    but the line doesn’t need to be too long
    only that is wider than a view, so that scrollbar is shown

    I do use DSpellCheck plugin, but I can’t test N++ without plugin because… I reverted to 7.5.8 ๏̯͡๏

    btw. this was happening in 7.5.9 x64 version



  • @abdelhameedma, @wolf-war and All,

    Refer to the link, below, where the issue is described :

    https://github.com/Predelnik/DSpellCheck/issues/151

    @predelnik ( Sergey Semushin ) have already produced a fix, below :

    https://ci.appveyor.com/api/buildjobs/s4mc8o0q6wum0e2i/artifacts/DSpellCheck.dll

    Please, abdelhameedma and wolf-war, could you check if it’s OK with that fix ?

    You may post your reply to Sergey, directly on GitHub. Thanks !

    Cheers,

    guy038



  • @guy038
    so far so good… I didn’t test it for long, but seems that fix is working
    thx for info



  • @Jeison-Rutz I was able to bring back responsiveness by simply unchecking from the menu Plugins --> DSpellCheck --> Spell Check Document Automatically (Alt+A). Responsiveness came back immediately, no restart required so there is definitely something wrong with that plugin.

    @guy038 Replacing the dll worked for me. I was able to re-enable spell check and responsiveness is still good. Thanks for finding the solution!



  • Hello, @don-ho and All

    Regarding my description of the bug, when switching tabs, here :

    https://notepad-plus-plus.org/community/topic/16468/notepad-7-5-9-release/23

    I also tried in a DOS Console window, with the command notepad++.exe -noPlugin and, unfortunately, the problem is still here : when you switch from, for instance, change.log to the big test file, containing long lines, it takes significant time :-((

    I just did that test to verify if the DSpellCheck plugin was concerned, because of the issue #151

    https://github.com/Predelnik/DSpellCheck/issues/151

    But, luckily, it’s a separated problem ! Or, at least, on a Win XP machine !

    Cheers,

    guy038



  • Hi, @harold-krueger-IV,

    I’m not the one who deserves thanks ! Indeed, it is Sergey Semushin (alias Predelnick), the creator of DSpellCheck, who found a solution ;-))

    Best Regards,

    guy038



  • Just to doublecheck and confirm @guy038 , DSpellCheck's issue has nothing to do with the big file tabswitch freeze.

    With a vanilla Notepad++ install, removing DSpellCheck (and all other plugins, via folder deletion) doesn’t change anything; results are the same as described in prior posts, for both the plain text and javascript test cases.

    Seems it’s basically cross-OS too:
    Debug:
    Notepad++ v7.5.9 (64-bit)
    Build time : Oct 14 2018 - 15:19:55
    Path : C:\Program Files\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : none

    I have an win xp machine I could try it on, but it looks like @guy038 already did that. I can say though that on win xp, prior Notepad++ versions always had the instant tabswitch with the background rendering.



  • I can reproduce now by comparing the performance between 7.5.8 and 7.5.9
    In my experience, the performance issue has gone after removing DSpellCheck.dll

    @Fox-E @Harold-Krueger-IV Could you remove DSpellCheck.dll then see if the issue has gone?

    @Predelnik Notepad++ 7.5.8 contains DSpellCheck 1.3.2, whereas Notepad++ 7.5.9 contains DSpellCheck 2.1.4 - so clearly there’s a performance issue in DSpellCheck 2.1.4.



  • Hi, Don, and All,

    • First, Don, after verifying from zip and 7z archives of N++ v7.5.9 ( in versions 32 or 64 ), I suppose that you meant that Notepad++ v7.5.9 contains DSpellCheck v1.4.6.0 ( and not 2.1.4 ?? )

    • Secondly, I re-tested my 7.5.9 local installation, after removing, either, DSpellCheck.dll file and, even, the DSpellCheck.ini file and the folder Hunspell and I can only conclude that the bug still occurs :-(( At least, on my Win XP laptop !

    So, seemingly, it would not be related to DSpellCheck !?

    Cheers,

    guy038

    P.S. :

    I had placed all DSpellCheck stuff, in the ..\plugins\Doc folder



  • @donho No change here, still getting the issue. Checked again just now with a fresh, vanilla 7.5.9 install, deleted DSpellCheck.dll, and tested with Normal Text.

    I did just notice though that you specifically have to switch tabs to see the issue; if you open a new tab, and paste a huge file in, it’ll instantly display (basically*) just fine. It’s only when you start switching tabs around that the issue happens.

    *: Obviously as you get into really huge files, like 20 MB or 100 MB, it takes more and more time to paste, but this is normal, and has nothing to do with tabswitch freezing.



  • Hi @don-ho, @fox-e, and All,

    And, above all, ONLY IF the Word Wrap feature is checked !!

    Cheers,

    guy038



  • I think I have found the issue and fixed it.
    Could you guys test this binary and confirm me that?
    https://notepad-plus-plus.org/temp/npp.zip



  • @donho That fixes it!

    For anyone else who wants to test that binary, it’s x86, by the way.



  • @Predelnik The issue has been identified. Sorry for the wrong presumption.



  • @don-ho and All,

    It’s OK for me, too, on my Win XP 32 bits laptop !

    Thanks for your quick debugging ;-))

    Cheers,

    guy038


Log in to reply