saving file name as text not pdf



  • I have been working with Notepad ++ for countless years and earlier this year I attempted to save a file with the same name as the pdf file I am working on for work reasons and the change of the end from .pdf to .txt did not work. I have been using the same name as the pdf file as the same name of the txt file for many years and for many files but the .pdf has to be taken out and after I do that, I can save the file and the program puts in .txt at the end and all is well. I asked some other technical people here at work and I was informed that it is a microsoft change that caused it and maybe it will be resolved sometime in the future but I at least want to open a discussion concerning this here. I love this program and use it in multiple ways on different computers to make my work tons easier in nature. I certainly love the macros defined on the program and they save a ton of time for me to do much work. Take care.



  • Can you look in your Windows File Explorer (File Explorer -> view ->Options -> and make sure “Hide extensions for known file types” is unchecked. This option is under the “files and folders” heading and is the 8th option down on my machine). In notepad++ go to Settings->Preferences->Default Directory and tell us if the “Use new style dialog (without file extension feature & Unix style path capacity)” is checked or not.

    The way I understand your question, you’re trying to do this:
    You have a pdf (we’ll call it willieo.pdf)
    You open willieo.pdf with a pdf reader (Acrobat for example)
    Copy some text
    Paste the text into notepad++
    You want to save the new notepad++ file as willieo.txt in the same directory as willieo.pdf so you go to File->Save As… and navigate to the folder the pdf is in, click on the pdf name, the pdf name populates the “File Name” part of the dialog box and then you delete the pdf extension in the “File Name” input box and hit save.

    At that point “the change of the end from .pdf to .txt did not work”. How did it not work? Does it overwrite the file willieo.pdf? Or does it just not give the new file an extension at all.

    If the Save As dialog box isn’t automatically putting a “txt” extension on your files, it may be easiest to just tell it the exact name you want to use and type the “.txt” yourself. I think the notepad++ “new style” dialog box expects you put in the entire file name, and the old one will append the “.txt” for you. So you may have to either type the extension yourself, or go to Settings->Preferences->Default Directory and uncheck the “Use new style” box.

    I love blaming Microsoft for things as much as the next guy, but I don’t think this is their fault.



  • Thank you very much. I checked in the order as you put it and the file explorer hide extensions for know file types is NOT checked.
    When I go to the settings preferences default directory the Use new style dialog is not checked or the open all files below it either.

    Now I did a test of a pdf file and it was a pdf file and changed the name to test.pdf. I then went to save the file with the same name at the beginning and hope the txt which I can see below in the save as bar would take out the .pdf and insert the .txt like it had done for many years but it said do you want to replace it and I said yes at least once and the file was an adobe extension in the file explorer directory and when I went to the file to open it, the adobe said it could not open the file. The file became a 1kb file in size and was still saved as test.pdf and I did not see it as a text file like I have to create for my work. I at least wanted to test with a file to see what would happen but I still have to take the file name and at least reduce it to test and note pad ++ does make the file .txt if there is not a period and some three letters that are there at all. Thank you for helping to have me investigate a few things today. Take care.


Log in to reply