Missing Plugin Menu in 7.6



  • I have installed the latest version (7.6 64-bit) and I no longer see a Plugin menu item. I have tried to uninstall and re-install it after deleting all Notepad++ setting folders that I found (AppData/Roaming/Notepad++ and /Program Files/Notepad++), but I can never get the Plugin menu to show. Am I missing something?

    Thanks,
    Rich



  • @richlux

    did you install to C:\Program Files with the option “Don’t use %APPDATA%” selected ?
    if yes this is a normal behavior of 7.6

    you shouldn’t select “Don’t use %APPDATA%” if you install to C:\Program Files or plugins and updater will not be shown

    so your options are:

    install to a custom folder you create
    (example C:\Applications\Notepad++)
    there you can activate "Don’t use %APPDATA%” in the installer
    this type of installation allows every user to see the same plugins and setting

    or

    make a default install without selecting "Don’t use %APPDATA%”
    this way every user has its own plugins folder inside %APPDATA%

    btw: can someone tell me why this specific topic has to be re-answered with the same working answers from different users again and again ? 😉



  • No, I did not check the “Don’t use %APPDATA%” option. I never do when I install or upgrade. I have uninstalled and re-installed multiple times, but I never get the Plugin menu. Looking under %APPDATA%, I only see 4 xml files (contextMenu, langs, shortcuts, and stylers).

    Rich



  • then it could be a user policy glitch or everything has been copied to the administrator account

    can you check each C:\Users local and roaming appdata if the plugins have been installed somewhere else ?

    C:\Users\USERNAME\AppData\Roaming\Notepad++
    C:\Users\USERNAME\AppData\Local\Notepad++

    especially:

    C:\Users\Administrator\AppData\Roaming\Notepad++
    C:\Users\ Administrator\AppData\Local\Notepad++

    if yes just try to copy them from there to your USERNAME at the same sub location

    the thing that always works, regardless of the computer’s windows internal %APPDATA% and %LOCALAPPDATA% mappings is:

    install to a custom folder you create
    (eg: C:\Applications\Notepad++)
    this time make sure you activate "Don’t use %APPDATA%” in the installer
    this type of installation allows every user to see/use the same plugins and settings



  • Bingo! I’m not an administrator on the computer, so when I installed Notepad++, I had to enter a username/password with Admin rights. The files were in the AppData folder of that Admin user. I copied them to my regular user’s AppData folder and now I see the plug in menu. I think the installer should put the files in the current logged in user’s AppData folder and not the admin account that is has to run as. Thanks so much for helping me resolve this.

    Rich



  • I have no problem with the plugin menu, but it seems to be missing the Explorer plugin. I’m moving to a new machine, so have to reinstall everything. Thoughts about where to get that plugin? Txs.



  • @Nickie-Albert

    The Explorer plugin is on its way to the plugin list, next release of Notepad++ should include it. In the meanwhile you can download it here.



  • @richlux

    I think the installer should put the files in the current logged in user’s AppData folder and not the admin account that is has to run as.

    unfortunately there are no windows environment variables for the invoker paths, so the installer does not really see anything else but the user environment it has been run with, eg. the admin in your case.

    glad you got it running



  • I just want to tell, that today the plugin admin entry was also missing at my installation (7.6 x64). Reinstalling Notepad++ brought it back again…



  • @dinkumoil Thanks!


Log in to reply