The strange behavior of the cursor in the Notepad + + window

  • Perhaps this option makes the problem?
    But I often need this option in the translator.

  • Since it seems to be QTranslate that’s causing Notepad++ to flicker:

    1. You should update to indicate what you’ve learned
    2. You might want to open a ticket with QTranslate – I think they’d probably have a vested interest in making their product work with as many GUI applications as possible. Besides, I think the default assumption will be “since Notepad++ only flickers when QTranslate is interfering, then it’s QTranslate’s problem, not NPP”. My guess is the QTranslate team would be able to debug whether it’s their problem, and if not, might know where to look for the problem on Notepad++ end.

  • It takes time to prove the guilt of QTranslate, perhaps this is a temporary coincidence.

  • @andrecool-68

    It takes time to prove the guilt of QTranslate, perhaps this is a temporary coincidence.

    you are a very good and thoughtful tester, i like 👍

  • When the cursor blinks again, I killed the “QTranslate” process in the task manager. This did not solve the problem.

  • That is unfortunate, but has not yet completely eliminated QTranslate (QT) as the culprit: QT may have put Notepad++ (NPP) into a state where it will continue to blink, even when QT is not running.

    The next experiment I would suggest: After NPP has started blinking, and after killing QT, exit normally from all instances of NPP, then rerun NPP (without re-running QT). Is it blinking right away? If not, after hours of running NPP without QT, does it start blinking? If not, then it it is probably QT causing the issue If it does eventually blink even without QT actively running, there is one more action to completely eliminate QT: do a reboot, and make sure QT is not run at all after the reboot (if it automatically runs after a reboot, you’ll need to disable that feature temporarily), and run NPP; if NPP starts blinking after a reboot when QT has not been run at all, then QT cannot be the culprit.

    If you are convinced that QT is not the culprit, it’s time for more debugging. Skimming back through the history, I see earlier that you say you only use the portable version… but you never really answered whether you have any plugins (the portable version can still use plugins). It may be that you have a plugin that is interfering. Showing us the result of the ?-menu, Debug Info, Copy debug info into clipboard will show if there are any plugins. Also, you can run notepad++.exe -noPlugin to ensure that you aren’t loading plugins.

  • This seems similar to which was fixed in Looks like there are some other cases need to be checked.

  • There is work around to this problem. Once mouse pointer is changed to cursor everywhere (specially on menu), then clicking on editable area resolves this issue.

    Moreover, this issue can be reproduced easily with the file attached on bug


    1. Open the above file in the Npp.
    2. Try to goto end of file (Bad allocation error will occur).
    3. Now close Npp and start again.
    4. As soon you start npp, bad allocation error will occur again. Keep on clicking on “OK” button on the messagebox.
    5. Once all the messageboxes are closed, the reported error can be seen.

  • @SinghRajenM

    thanks for your ideas.

    i’m trying to reproduce the flicker using your git post but i can’t get the bad allocation error with the file at
    i can scroll down to the end without any issues.

    i’ve tried in np++ 7.5.5 and 7.6.2 x86 with dspellcheck 1.4.6 and 1.4.9
    do i need any special setting in dspellcheck to trigger this error ?


    what happens if you activate multi line tab bar ?
    (settings > preferences > general > tab bar >>> multi-line)

    are there any changes depending on how many tabs are open ?
    (answer: no … i’ve just answered this question myself by rewatching your videos ;-) )

  • QTranslate Portable Version, There is nothing in autoload, not even antivirus. I myself can’t call that hallucination, it happens by itself.
    And I’m glad to know that I’m not crazy. Such problems were with others! Just no one knows how to fix this problem.
    I have this editor for many years, and I do not want to part with it.

    Notepad++ v7.6.2 (64-bit)
    Build time : Jan 1 2019 - 00:02:38
    Path : C:\Tools\npp.7.6.2.bin.x64\notepad++.exe
    Admin mode : ON
    Local Conf mode : ON
    OS : Windows 7 (64-bit)
    Plugins : ComparePlugin.dll DSpellCheck.dll HTMLTag.dll JSMinNPP.dll mimeTools.dll NppConverter.dll NppExec.dll NppSnippets.dll XMLTools.dll _CustomizeToolbar.dll

  • If it’s not the QTranslate, then my next best guess is it’s a variant of what @SinghRajenM described – hopefully, he can chime in more and help you run experiments regarding that possibility. If it’s not that, then you’ve got a few plugins, some of which I have no experience with, so my -noPlugins experiment would be what I tried next.

  • I did not understand what error should appear pi these actions.

  • @Meta-Chuh, I reproduced flicker error with npp V7.6.1. while the bad allocation error was reproduced with DSpellCheck V1.4.8.

    @andrecool-68 the error looks like screenshot added at

  • @SinghRajenM said:
    I do not have such an error

Log in to reply