Stuck in "Administrator" mode...how to get out?



  • On my computer, I am a lowly user:

    Imgur

    But whenever I run portable Notepad++ directly from its exe file (no shortcut involved) I end up in Administrator mode:

    Imgur

    How can I prevent this from happening?

    I seem to recall someone else having this problem recently, but I can’t find the postings ATM. And I don’t think there was a resolution in that thread anyway. But could be wrong in which case I’d appreciate being pointed there if anyone knows where it is.



  • @Alan-Kilborn

    very strange, are you sure, that you don’t have another instance in admin mode running?
    Does this happen even after a reboot?



  • @Eko-palypse said:

    are you sure, that you don’t have another instance in admin mode running?

    I am sure that this is not the case.

    Does this happen even after a reboot?

    Yes, it seems to be the standard way for N++ to run itself lately. I’m sure my I.T. dept did something “interesting” recently which now causes this to happen, but I’ve no idea what so that I can attempt countermeasures.



  • @Alan-Kilborn

    what happens if you download and extract a fresh 7.6.2 (or a very old 6.x) portable zip to your desktop ? same ?
    does it do the same regardless if the portable release is x86 or x64 ?

    does it make a difference if you rename notepad++.exe to npp.exe and start it ?
    (if the cause is a policy filter by file name)

    and if you right click on both notepad++.exe’s and open properties > compatibility, is run as administrator checked and greyed out, or is it unchecked or checked ?
    (there’s also a button for a second compatibility settings page for all users, where you can check if runas administrator is activated)



  • @Meta-Chuh

    what happens if you download and extract a fresh 7.6.2 (or a very old 6.x) portable zip to your desktop ?
    does it do the same regardless if the portable release is x86 or x64 ?
    does it make a difference if you rename notepad++.exe to npp.exe and start it ? (if the cause is a policy filter by file name)

    I tried all of those situations. In all of those cases “[Administrator]” always shows in the title bar of N++.

    and if you right click on both notepad++.exe’s and open properties > compatibility, is run as administrator checked and greyed out, or is it unchecked or checked ?

    Run as Administrator is greyed out and unchecked

    (there’s also a button for a second compatibility settings page for all users, where you can check if runas administrator is activated)

    Yes but a popup comes up when I press this button saying my activity will be logged if I continue on…sheesh. I didn’t continue.

    Thx for the ideas @Meta-Chuh



  • @Alan-Kilborn ,

    If you try running cmd.exe from double-clicking the executable, does it prefix the title bar with “Administrator:”? I am wondering IT left your machine in a state where everything is running as administrator. (I know I had mine running always-as-admin a few years back, but I have forgotten how I did it or undid it – maybe someplace in the UAC settings)



  • @PeterJones said:

    If you try running cmd.exe from double-clicking the executable, does it prefix the title bar with “Administrator:”?

    It does NOT.

    I am wondering IT left your machine in a state where everything is running as administrator

    If this were true it would actually ease my current problem…drag-and-drop (into Notepad++) failures. :)



  • Have you checked your registry? this thread was trying to force it to open in Administrator mode, but if similar entries had the RUNASADMIN already, then maybe deleting those entries would work…

    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers
    

    You might also check whether one of your entries like HKEY_CLASSES_ROOT\Applications\notepad++.exe or HKEY_CURRENT_USER\Software\Classes\Applications\notepad++.exe has a runas verb as well as (or instead of) an open verb.

    Maybe start searching the registry for notepad++.exe and/or runas – it will find some irrelevant ones, but might find you what you are looking for…



  • @Alan-Kilborn

    @PeterJones 's good ideas regarding cmd and runas also made me think:
    what would happen if you start a cmd window and execute runas /trustlevel:0x20000 "Your_Path_To\notepad++.exe" ?

    does np++ still show [Administrator] in the title bar and in the debug info ?



  • Hi, @alan-kilborn, @meta-chuh, @peterjones, @eko-palypse,

    Maybe what I’m about to say sounds silly, as I’m not a coder, ( yet! ), but why not look at the part of N++ code, responsible for the display of [Administrator] in the N++ title bar ?

    Probably, this occurs, ONLY IF several, conditions are, simultaneously, true ! Then, you would have to verify if each of these individual conditions is checked or not, in Alan’s configuration ?!

    Cheers,

    guy038



  • I looked in the registry but didn’t see any weirdness such as Peter suggested. Trying Meta Chuh’s runas command resulted in N++ running and still presenting “Administrator” in the title bar… :(



  • @guy038 said:

    why not look at the part of N++ code, responsible for the display of [Administrator] in the N++ title bar ?

    Not an unreasonable suggestion at this point. :)

    Here’s how the title bar gets set:

    void Notepad_plus::setTitle()
    {
        if (_isAdministrator)
            result += TEXT(" [Administrator]");
    

    Which leads back to how _isAdministrator is determined:

    Notepad_plus::Notepad_plus()
    {
        // Determine if user is administrator.
        BOOL is_admin;
        winVer ver = NppParameters::getInstance()->getWinVersion();
        if (ver >= WV_VISTA || ver == WV_UNKNOWN)
        {
            SID_IDENTIFIER_AUTHORITY NtAuthority = SECURITY_NT_AUTHORITY;
            PSID AdministratorsGroup;
            is_admin = AllocateAndInitializeSid(&NtAuthority, 2, SECURITY_BUILTIN_DOMAIN_RID, DOMAIN_ALIAS_RID_ADMINS, 0, 0, 0, 0, 0, 0, &AdministratorsGroup);
            if (is_admin)
            {
                if (!CheckTokenMembership(NULL, AdministratorsGroup, &is_admin))
                    is_admin = FALSE;
                FreeSid(AdministratorsGroup);
            }
        }
        else
            is_admin = false;
    
        _isAdministrator = is_admin ? true : false;
    }


  • I suppose I will just “live with it”. It appears that however I.T. has my account set up, it isn’t going to play well anymore with Notepad++. Asking I.T. to “fix” what they’ve done would likely be counterproductive as I’d probably end up with a worse situation.

    I remember when computers were engineering tools. I’m not sure what they are now, but I don’t think it is that. :(



  • How is it generally with a user account?
    Here is an example of two programs on the same machine.



  • @Alan-Kilborn

    i think i found something i can reproduce:
    i’ve set up a windows 7 x64 bit test vm with a standard user.
    if i start notepad++ portable or installed, it loads as this default user.

    i’ve then entered the user settings and slided the user access control slider from default down to off (disable uac) and rebooted.

    tadaaaa: from now on i always see [Administrator] in the notepad++ top bar, even if it is not running as administrator.

    maybe it’s the same on your system ?
    maybe the it guy temporarily disabled uac because he was annoyed by it while he was setting up something, and he just forgot or didn’t bother to re-enable it again ?



  • @andrecool-68

    i think that administrator detection of newer versions of notepad++ relies on an active user access control.
    what happens if you re-enable uac and set it to default for a test, then reboot ?
    does it still say [administrator] in your portable 7.6.2 or is it gone then ?

    alt



  • True UAC is disabled!



  • Yesterday I reinstalled the 7x64 operating system, and turned it off myself.



  • @Meta-Chuh

    Here’s how that screen looks for me:

    Imgur




Log in to reply