N++ freezes for some seconds (mark long text area with SHIFT+Pagedown)



  • Hello,

    I’m really loving Notepad++ (32/64bit v7.6.3) !

    I have a 13MB text file (SQL dump) with ~260.000 lines.
    When i try to mark a longer text area of more than thousands lines (pressing SHIFT+Pagedown for a longer time),
    N++ freezes for 2-10 seconds, after that i can mark some more pages (always pressing SHIFT+Pagedown),
    but N++ freezes again for 2-10 seconds, and so on…

    I have tried it on my Intel i5 Notebook and my i7 PC - same problem.
    But no problem when i’m using the stupid original Windows Editor.

    Best regards
    Michael



  • It may be that the lexer is having trouble keeping up, if you have a lexer (“language”) active to apply highlighting. In the lower-left on the Status Bar, do you see “Normal text file” or “Structured Query Language file” or something else (if it just starts with length: ### then you might have to maximize the window to see the file-type indicator). Or you could look in the Language menu – if SQL is active, Language > S > ● SQL or Language > ● SQL will have a big DOT ● next to it to indicate it’s active; if it’s normal/plain text, N > ● Normal text will have the ●)

    There are also other plugins that might be interfering and slowing things down. Grabbing the menu item ? > Debug Info > Copy debug info into clipboard and pasting it into your reply here will help us know your setup. If you want to try without plugins, you can use the -noPlugin command-line-argument (%ProgramFiles%\Notepad++\Notepad++.exe -noPlugin or %ProgramFiles(x86)%\Notepad++\Notepad++.exe -noPlugin from the Windows Run Dialog (Win+R), assuming you have installed into normal locations) to run with plugins disabled.



  • @Michael-Rosenbaum

    Maybe try the Edit menu’s Begin/End Select command. Execute it once at the top of the block you intend to select, move to bottom of desired block, execute Begin/End Select again.


Log in to reply