Notepad++ Failed to Start after Windows 10 Updates (Ninite)



  • I just wanted to inform you that my Notepad++ failed to start after the new windows 10 update (not responding when launched). The update itself seems buggy and failed to go through on several occasions. After clearing the update cache the windows update was a success. I originally installed notepad++ from ninite.

    Updates Installed

    • Feature update to Windows 10, version 1809
    • list itemKB4483452
    • list itemSecurity Update for Adobe Flash Player: February 12, 2019
    • list itemUpdate for Adobe Flash Player: October 9, 2018

    Notepad++ Information
    Notepad++ v7.6.3 (32-bit)
    Build time : Jan 27 2019 - 17:20:30
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll

    After doing a reinstall over the top with Ninite it seems to be ok again but I just wanted to report the issue. I would provide a log file but I searched for about half an hour on the wiki and search engines and could find no information on how to do this.



  • welcome to the notepad++ community, sir @Galahan_

    thank you for reporting your 1809 update experience and the way you’ve been able to fix it’s aftermath.

    yes you are correct.
    as you have been able to resolve this issue, by re-installing notepad++ 7.6.3 x86 on top of your installation, you already know that some notepad++ files and/or settings were corrupted by the update.

    this is one of many known possible 1809 issues, and quite a few people have been experiencing similar problems with different software packages, video drivers that result in a completely black screen after upgrade, or even partial private data loss, after installing the 1809 update.
    (note: microsoft currently keeps patching this update again and again, but the id stays the same, leading to problems installing it at all without clearing the update folders, as already downloaded parts differ from the newer 1809 package, like you have also experienced)

    the way you installed notepad++ is not the cause to this result, especially because your installation also worked before the update.
    installing with either via ninite packaging the original installer, or manually using the notepad++ installer itself, usually produces the same result.



  • Thanks for the reply, I’m glad you’re on top of the problem.



  • I thought the problem was over but tonight it won’t start again. I was using it only 10mins ago as well @Meta-Chuh .



  • @Galahan_

    please try to download a portable version from >>> here <<<,
    extract it to your desktop and start it by double clicking on notepad++.exe inside this portable folder.
    (the portable version can coexist with your normal installed version and does not modify, or get in conflict with any other installed notepad++)

    then test this fully featured portable version with anything you like, including exiting it and starting it again (by double clicking on the portable notepad++.exe).

    if this works, it is sometimes enough to delete following folders of your installed notepad++, including their contents, to get your installed notepad++ 7.6.3 32 bit running again.

    folders to delete:
    %AppData%\Notepad++
    %ProgramData%\Notepad++ (if it exists from a previous installed version)
    %LocalAppdata%\Notepad++ (if it exists from a previous installed version)

    the folder and contents of %AppData%\Notepad++ will be restored with default values, after a relaunch of your installed notepad++.

    note: some plugins that store data at this location may need to be reinstalled to create them newly.



  • I was in w10, had installed 1511 that got updated to 1607, 1803, 1809
    but all software continued working as earlier.

    Seems problem is not related to windows update.



  • @vsrawat you might have different plugins, drivers etc.

    I might just try removing Notepad++ completely inc appdata etc and reinstalling via typicalinstaller.



  • I uninstalled notepad++ and deleted all folders inc appdata / program files. I reinstalled the program from the website. But today it still hanged and crashed. I had a look in event viewer and found this:

    Event ID: 1002
    Source: Application Hang
    Level: Error

    The program notepad++.exe version 7.6.3.0 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
    Process ID: 237c
    Start Time: 01d4cd18da99fa5d
    Termination Time: 11
    Application Path: C:\Program Files\Notepad++\notepad++.exe
    Report Id: 74ea35dd-1e36-480b-bd71-798b39a562c5
    Faulting package full name:
    Faulting package-relative application ID:
    Hang type: Cross-process

    I also found this relating to my Logitech keyboard and mouse software:

    Fault bucket 2254924583241629966, type 5
    Event Name: AppHangXProcB1
    Response: Not available
    Cab Id: 0
    Problem signature:
    P1: notepad++.exe
    P2: 7.6.3.0
    P3: 5c4dd9e9
    P4: 42b2
    P5: 134217760
    P6: logitechg_discord.exe
    P7: 9.0.42.0
    P8:
    P9:
    P10:
    Attached files:
    \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERCA61.tmp.WERInternalMetadata.xml
    \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERCA81.tmp.xml
    \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERCA80.tmp.csv
    \?\C:\ProgramData\Microsoft\Windows\WER\Temp\WERCA91.tmp.txt
    \?\C:\Users\USER\AppData\Local\Temp\WERD187.tmp.appcompat.txt
    These files may be available here:
    \?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppHang_notepad++.exe_b73415552dca81df43e899c9342a0e63499421b_5b96aec2_01c1dc14
    Analysis symbol:
    Rechecking for solution: 0
    Report Id: 74ea35dd-1e36-480b-bd71-798b39a562c5
    Report Status: 268435456
    Hashed bucket: a2e6f48512a39c1d4f4b19f61b69c10e
    Cab Guid: 0

    So next step will be to upgrade or reinstall the Logitech software.



  • I am currently using Logitech usb mouse, and in the past I have used Logitech keyboard for years, alongwith npp and there never was any problem, that was for w10 and earlier windows as well.

    I don’t have solution for your problem, but I guess hardware device conflict can’t be the reason for a normal stable software not working. Look for some other solution.

    You can borrow a mouse or keyboard (or whatever logitech device you have) from a neighbor and put that and see whether using that instead of Logitech’s stops hanging.



  • @vsrawat I’m using “Logitech gaming software” which comes with the drivers for this keyboard and mouse. An update of software and firmware did not help the issue though, may try the portable np++.



  • @Galahan_

    i was going to suggest, that you try out the 64 bit version, as we recently had a report, that another user has also experienced notepad++ 32 bit freezes on his windows 10.
    only the 64 bit version seemed to work for him …
    … but as i can see at your crash report, you’ve already tried that too. 👍

    in case you haven’t tried this yet: you could first try to boot into safe mode and check if your installed notepad++ can be started properly, and does not freeze.
    (see >>> 8 ways to boot into Windows 10 Safe Mode <<<)

    this way you can check if any other startup software or drivers may be the culprit, as they will not be loaded in safe mode.
    (if it still crashes in safe mode, we can e.g. exclude the logitech drivers as a cause)

    another thing you could try (again, if you haven’t done so already 😉 ), is to reboot normally, and create a new local user account, to check if it has a system wide cause, or if it is working properly, once you log into a completely new user hive.

    please keep us informed about anything you discover, if you have the time to do so.
    it might be of help to other users.

    best regards



  • @Meta-Chuh I’m using 64bit already and still get the same issues. I’ve downloaded the portable version which hasn’t had any issues so far.

    I might do a hdd format soon and will know then if the problem gets carried over.



  • The hdd format fixed the issue.


Log in to reply