Bug - Attempting to save with a bar ( | ) in the file name results with "Please check if the file is open in another program"



  • I noticed just saving a plane text file, created in notepad++, with a file name containing a bar symbol results with the message “Please check if the file is open in another program”. Is this known? I wasn’t sure where else to look for bugs.



  • @Jonni-Dillon

    unfortunately windows itself will prevent you from creating a file with an | in it’s name, as this is the pipe character.
    you can crosscheck this if you try to rename a test.txt file to test|test.txt using windows explorer.

    albeit if you already have a file, from a mac or linux machine, that’s already called e.g. test|test.txt you will be able to edit and save (update) that file, but you won’t be able to “save as” even with the same name, if it has a |in it’s file name.

    for this it’s best to save them as test--test.txt, and then rename them to their desired name test|test.txt on your mac or linux machine.



  • @Meta-Chuh Should notepad++ not be responding with a message other than “Please check if the file is open in another program” though?



  • @Jonni-Dillon

    Should notepad++ not be responding with a message other than “Please check if the file is open in another program” though?

    yes, and it will, if you go to settings > preferences > default directory and activate use new style dialog as seen at the screenshot below:

    Imgur

    after you have selected use new style dialog and restarted notepad++, it will behave the following way:

    • if you try to “save as” or “rename” a file, that already has a | in it’s file name, it will not permit it and not even present you with a save as or rename dialogue.
    • if you try to “save as” or “rename” any file that does not have a | in it’s filename yet, by adding a | to it’s current file name, it will correctly tell you “the file name is not valid” in an alert window.

    note: the use new style dialog is the prefered open/save dialogue setting if you are using a mac/linux/windows mixed environment, like i do.


Log in to reply