Replace interface modification - suggestion

  • A small point on the replace menu I just just fell into.

    If you want to search for something that does not require a regular expression but want to replace it with something that does require a regular expression you need to select reqular expression under search mode. i.e this changes both the search & replace modes.

    The words should be changed from ‘Search Mode’ to ‘Search and / or replace mode’

    I was trying to split a string at each (of 51) ampersands to make it easier to read hence my search string was ‘&’ and the replace string ‘&/n/r’.

    My first couple of attempts just replaced ‘&’ with ‘&\n\r’ befor I realised the reg ex button also changes the replace behaviour. Obvious once you have found it but frustrating for new uses until they discover it


  • @John-Murrell

    Or maybe just “Mode”.

  • or maybe “Search and Replace Mode”.
    (the “or” might also be confusing)

  • I suggested “mode” because we are already in the “find” (“search”) and/or “replace” area…so those things are rather implied and just extra clutter IMO.

  • @Alan-Kilborn

    true, i might tend to repetitions, to make things as descriptive as possible, at as many places as possible, if possible ;-)


    if you like, you can modify (customise) all your notepad++ menus, titles and texts, by editing the file: your_program_files_path\Notepad++\localization\english.xml.

    (i know, it’s not really necessary anymore, now that you know how the search mode behaves, but i’d completely understand, if it gets stuck at the back of your eyes, being a daily reminder of your experience)

    for the search/replace mode text, change:

    <Item id="1624" name="Search mode"/>

    to e.g.:

    <Item id="1624" name="Search and Replace mode"/>

    after saving english.xml, you need to head to settings > preferences > general and change your localization to any other language and back to english, in order to reload all english menus and texts.

    note: a notepad++ restart does not suffice to reload english.xml, so you have to swap your language briefly.

Log in to reply