Cannot install plugins at all



  • @Meta-Chuh ,

    Thank you, I appreciate your kindness ;)



  • @pnedev said:


    If you install plugins manually you need to create separate plugin folder per plugin,
    So you need to have D:\tools\Notepad++\plugins\PluginXName\PluginXName.dll

    Thanks @pnedev , this helped.
    For anyone else who’s got the same problem - notice that the folder name should be exactly the same as the DLL name (as actually mentioned in the quote above)



  • I had similar issue with the proxy preventing me from installing any plugins. I was able to resolve it by manually creating a gupOptions.xml file with the proxy address. I used the following to help https://notepad-plus-plus.org/community/topic/13030/problem-with-set-updater-proxy/5



  • @amathub ,

    You can now do it directly from Notepad++.
    Go to the help and about menu - ? and you’ll see Set Updater Proxy ....

    BR



  • @pnedev thanks, I should have clarified that I had a similar issue above that someone else was having where going to the setting “Set Updater Proxy …” would not retain the proxy address. I would set the proxy there, but going back to the setting would show 0.0.0.0 again.

    After manually creating the missing gupOptions.xml file with the proxy address, it would then show up in the “Set updater Proxy …” location. I could then also install plugins after that as well.

    Thought I’d pass the info along to anyone else requiring the use of a proxy that wasn’t sticking in the setting.



  • @amathub ,

    Thanks for sharing. I never actually used that just know that the setting is there but never tested if it is working.



  • @amathub

    it’s necessary to open notepad++ elevated as administrator, due to the permissions required for %ProgramFiles(x86) or %ProgramFiles, to save the changes to e.g. %ProgramFiles(x86)\Notepad++\gupOptions.xml lies.

    our apologies, if we did not mention this, and that it is a bit confusing, as the proxy settings panel will not throw a permission warning, but just exit without modifying gupOptions.xml.

    many thanks and best regards.



  • off-topic aside to @Meta-Chuh:

    %ProgramFiles(x86) or %ProgramFiles%ProgramFiles(x86)\Notepad++\gupOptions.xml

    You seem to be dropping the closing % from Windows variables recently. It should be:

    %ProgramFiles(x86)% or %ProgramFiles%%ProgramFiles(x86)%\Notepad++\gupOptions.xml



  • @PeterJones

    thanks, and sorry for the typo.



  • I found that when I had plugins listed in the Plugin Admin’s Update tab, that until I updated those plugins, I could not get a new plugin to install.


Log in to reply