Cannot install plugins at all



  • @pnedev

    Since here we are getting quite a lot “I-cannot-install-plugins” kind of help requests recently perhaps it will be good to make pinned thread

    good idea, i second that.

    This will save us (you mainly as I don’t frequently answer) a lot of time answering the same questions again and again.

    maybe not hyper-frequently in the past, but very active and always very useful as well as productive … and you are more active lately, which i personally encourage and enjoy a lot ;-)

    I suppose if Plugin Install Problems FAQ thread is written Don can pin it so it shows in the very beginning of Help Wanted and Plugins Development.

    @PeterJones , @guy038 and me have started a little brainstorming discussion about that >>> here <<< and guy has some ideas to improvements, which we can do autonomously.
    you are very invited to join with anything that’s on your mind … or just for the fun of it ;-)

    I would also suggest a small addition to Notepad++'s future versions - on startup to check the plugins folder for any DLLs. If such are present to show message saying that those are not supposed to be there and will not be loaded.

    a request for the old plugin manager was submitted.
    Remove the “Plugin Manager” plugin on Notepad++ 7.6.x and above due to incompatibility. #5409
    i chose the removal option, fearing that a message will be clicked away and ignored by many users.

    What do you think?

    i’m completely with you.



  • @Meta-Chuh ,

    Thank you, I appreciate your kindness ;)



  • @pnedev said:


    If you install plugins manually you need to create separate plugin folder per plugin,
    So you need to have D:\tools\Notepad++\plugins\PluginXName\PluginXName.dll

    Thanks @pnedev , this helped.
    For anyone else who’s got the same problem - notice that the folder name should be exactly the same as the DLL name (as actually mentioned in the quote above)



  • I had similar issue with the proxy preventing me from installing any plugins. I was able to resolve it by manually creating a gupOptions.xml file with the proxy address. I used the following to help https://notepad-plus-plus.org/community/topic/13030/problem-with-set-updater-proxy/5



  • @amathub ,

    You can now do it directly from Notepad++.
    Go to the help and about menu - ? and you’ll see Set Updater Proxy ....

    BR



  • @pnedev thanks, I should have clarified that I had a similar issue above that someone else was having where going to the setting “Set Updater Proxy …” would not retain the proxy address. I would set the proxy there, but going back to the setting would show 0.0.0.0 again.

    After manually creating the missing gupOptions.xml file with the proxy address, it would then show up in the “Set updater Proxy …” location. I could then also install plugins after that as well.

    Thought I’d pass the info along to anyone else requiring the use of a proxy that wasn’t sticking in the setting.



  • @amathub ,

    Thanks for sharing. I never actually used that just know that the setting is there but never tested if it is working.



  • @amathub

    it’s necessary to open notepad++ elevated as administrator, due to the permissions required for %ProgramFiles(x86) or %ProgramFiles, to save the changes to e.g. %ProgramFiles(x86)\Notepad++\gupOptions.xml lies.

    our apologies, if we did not mention this, and that it is a bit confusing, as the proxy settings panel will not throw a permission warning, but just exit without modifying gupOptions.xml.

    many thanks and best regards.



  • off-topic aside to @Meta-Chuh:

    %ProgramFiles(x86) or %ProgramFiles%ProgramFiles(x86)\Notepad++\gupOptions.xml

    You seem to be dropping the closing % from Windows variables recently. It should be:

    %ProgramFiles(x86)% or %ProgramFiles%%ProgramFiles(x86)%\Notepad++\gupOptions.xml



  • @PeterJones

    thanks, and sorry for the typo.


Log in to reply