Writing in Italian language



  • Hi, I write the HTML text in Italian, but when i save it, the italian special character “é” is saved as “?”.
    Probably also other special characters are not saved correctly. Why Notepad++ don’t save the text as is written?
    In the Notepad++ ver 7.6.6 the language is configured as Italian.
    Thanks
    Luigi Ferrari
    ferraril@tiscali.it



  • @Luigi-Ferrari

    Are you saying that you are typing words and everything is looking ok.
    After saving the file and NOT REOPENING/RELOADING the file those characters
    do get converted? I don’t think so. I assume you meant after reopening or reloading
    the document you see question marks instead of e.g. é.
    If this is the case, then I assume that you have enabled autodetect character encoding
    which is configurable via settings->preferences->misc..
    If this isn’t what you were talking about then you need to be a little bit more specific
    what exactly happens, when and where.



  • In what encoding do you save your file?
    What encoding is written in the head of the document?
    <meta charset="utf-8">



  • @Luigi-Ferrari
    With utf-8 encoding works well


Log in to reply