Something wrong with the latest version



  • V7.6.6
    issue 1
    select lines of text replace word then is repeated on each line with “in selection” box ticked changes on all lines in file not just the selected ones

    issue2: change text by hand cases a box to appear with optional text the the only issue is you have to click on the box before it will let you change the text on the line, very annoying

    file type is “.bat”



  • @Michael-H

    I don’t have a prayer at understanding what your “issue 1” means.

    For “issue 2” it sounds like Auto Completion is turned on. Turn it off in the Preferences and you should be good to go.



  • Yep Auto completion for word and function seem to be turned on as default
    The fist issue is that on the Replace window the “In selection” tick box is not selected then you first select a number of lines and then select the find and replace button



  • @Michael-H said:

    The fist issue is that on the Replace window the “In selection” tick box is not selected then you first select a number of lines and then select the find and replace button

    …and…?

    Are you expecting the “In selection” to be auto-ticked in this circumstance? It will be if you select “enough” text first before invoking Replace with ctrl+h.

    Or are you going in a different direction with this? I still really can’t tell. Anyone else care to take a stab at it?



  • I was expecting the “in selection” box to be ticks when I first select a number of lines before selecting the find and replace as in I have already selected the line I want to change, but the tick box is not ticked when the replace window is first displayed (not updated)

    Thanks



  • @Alan-Kilborn said:

    It will be if you select “enough” text first

    I was curious, so I ran experiments: apparently, for me right now, it’s 1025 bytes – I had 1024 bytes selected, and it didn’t start enabled; I had 1025 bytes selected, and it did start enabled.

    Once it is ticked, if you close the replace dialog and select less than 1024, and Ctrl+H again, it will remain with “in selection” enabled, as long as you have something selected. After you either run Ctrl+H with no selection, or manually disable that option, then the next Ctrl+H will again have the 1025-byte threshold to enable the checkbox.

    @Michael-H, my suggestion to you would be to try selecting 1025 bytes or more. If that’s not viable, then this FAQ explains where to make a feature request, where you can ask for the automatic “in selection” box-enabling to be at a lower threshold



  • @PeterJones said:

    automatic “in selection” box-enabling to be at a lower threshold

    As an addendum: The problem with a lower threshold is that many users want to be able to select two or so lines of text, and search the rest of the document for those same lines. That is possible now… but if the threshold were made too short, it might frustrate that use case.

    It’s hard to make everybody happy at the same time with software design decisions.


Log in to reply