"File not found" when trying to save a new file



  • I updated to v7.6.6 and when I try to save a new file it tells me file not found, which is the point because it’s a new file. Also upon updated all of my plugins disappeared.

    Steps: Click new document, type something, try to save.
    I’m on Windows 10.



  • welcome to the notepad++ community, @SuperVillainPresident

    for the file save glitch:
    please go to settings > preferences > default directory and check that use new style dialog is enabled.

    for the plugins:
    yes, the plugin folder structure has changed since version 7.5.9.
    all plugins have to have their own sub-folder now, instead of all dlls being located at the plugins folder.
    your plugins are still there, but you need to migrate them, by creating a sub-folder for each.
    (alternatively re-download your plugins using the built in plugins admin located at the plugins menu)

    plugin migration:
    please go to plugins > open plugins folder...
    create a folder with the same name of the plugin, but without the .dll name, for each of your old plugins.
    example: for HexEditor.dll the new folder should be called HexEditor
    then copy your plugin .dll into this folder.
    after a notepad++ restart, your old plugin should be visible again.



  • @SuperVillainPresident

    Concerning the file not found issue I assume we need more information about what exactly you do, which plugins are installed (see debug-info from ? menu) in order to find out why this it not working for you.

    Regarding the plugins, since 7.6 the directory layout has changed. Each plugin must now be within it own directory. Check if your plugins are installable via the new plugins admin.



  • @Ekopalypse Here is the debug information.
    Notepad++ v7.6.6 (32-bit)
    Build time : Apr 3 2019 - 23:49:50
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : ComparePlugin.dll DSpellCheck.dll JSLintNpp.dll JSMinNPP.dll mimeTools.dll NppConverter.dll NppExport.dll NPPJSONViewer.dll XMLTools.dll

    @Meta-Chuh enabling “use new style dialog” didn’t fix the file not found issue.



  • @SuperVillainPresident

    what happens if you open up a completely new tab, and copy-paste the content of the “file not found” tab there ?
    can you save a completely new created tab without an alert window saying “file not found” ?



  • @SuperVillainPresident

    thank you for the info.
    Could you describe what exactly you do (step by step) to create the file not found issue?



  • @Ekopalypse @Meta-Chuh
    The steps are

    1. Open blank document
    2. write some text
    3. click the save icon
    4. Click save, then it would give the message

    Strange thing is I tried those exact steps just now and it saved it without issue. I reopened the files and the text was there. Initially I tried creating an empty text file, so that the file did exist, and it would let me save, but the text didn’t get saved. I haven’t done anything since yesterday. I put my computer to sleep and woke it back up and it’s saving now. I appreciate your help.



  • @SuperVillainPresident said:

    I tried creating an empty text file

    How exactly did you do that? Empty files are not saveable. Of course if you type a single character into an empty file and then backspace it away, it is then saveable…



  • @SuperVillainPresident

    sorry, seems that I wasn’t clear, I expected something like

    1. started npp as administrator
    2. I press CTRL+N to create a new document
    3. typing “hello world”
    4. pressing CTRL+S to save the document

    or what ever you did, in order to find out whether those steps create the same issue
    on other installations. I mean, it can be safely assumed that such a basic actions
    does work, in general, and if it doesn’t work then there is this need to have the exact
    and as detailed as possible description, to get a chance to find out what might have
    caused this.



  • So, in case anyone is having a similar issue, it was a Windows Defender problem. I guess it was in the last update that there is a Folder Access permission that was set to on. You can either turn it off or set notepad++ to be allowed access. Here is the link that fixed it for me:

    https://answers.microsoft.com/en-us/windows/forum/windows_10-files/file-not-found-check-the-file-name-and-try-again/0734e837-b9f7-485e-93c5-5592f804b4c8


Log in to reply