Autocomplete bug in 7.6.2 and later?



  • We have xml files for our syntax, which work in 7.6.1 and earlier builds of Notepad++, but the later builds do not offer the autocomplete possibilities in the same way.

    The older builds would allow words used in the file, as well as commands from the syntax files, to be shown as autocomplete options.

    The new builds (regardless of configuration settings in preferences/autocomplete) will only show words and/or commands that exist in the file. I cannot get the full listing of commands from the syntax files to show up as autocomplete options unless the command already exists in the file. I verified that the syntax files are in place and correct. The commands still highlight correctly according to the syntax files, but autocomplete is broken.

    Does anyone know of a fix for this?



  • @Charlie-Fuller

    the missing autocomplete experience, might be due to the folder location changes of the newer notepad++ releases, causing the installer not to automatically select the autocompletion option when updating.

    (the old folder location was Notepad++\plugins\APIs, and the new folder location is Notepad++\autoCompletion\)

    the usual fix is to install notepad++ again, on top of your existing notepad++, and make sure that autocompletion is activated at the installer.
    (recommended version: 7.6.6)


    here are some details from a similar issue:

    please check if C:\Program Files (x86)\Notepad++\autoCompletion\xml.xml exists. (folder location example of a default 32 bit install)

    • if it does not exist, please download the 7.6.6. 32 bit installer from >>> here <<< ,
      or the 7.6.6. 64 bit installer from >>> here <<< ,
      and re-install it on top of your existing notepad++.
      important note: make sure that auto-completion files is selected when re-installing.

    • if it does exist, please go to settings > preferences > auto-completion and check that function and word completion and function parameters hint on input are activated, as seen at the screenshot below:

    best regards.


Log in to reply