"Windows cannot access the specified device path, or file."



  • Installed Notepad++ update (from v7.6.4) v7.6.6 on W10pro PC and tried both ‘32-bit x86’ and ‘64-bit x64’ versions with same results when tried to open a .txt file:
    “Windows cannot access the specified device path, or file. You may not have the appropriate permissions to access the item.”

    All /notepad++ folder permissions are set to ‘allow’.

    Went back and installed v7.6.4 and all seems ok again.

    Thoughts ?



  • welcome to the notepad++ community, @Ak-M

    Thoughts ?

    not really, at least not yet.

    as both version 7.6.4 and 7.6.6 are not code signed, and 7.6.4 works, i would exclude a security policy, that prevents unsigned code to access your data files.

    if you have time and dare testing pre-release versions, you could also try the current 7.7 release candidates from >>> here <<<, to see if they would work on your system. they are code signed again, so maybe they could work, if it is a security setting or protection software that causes this.
    (portable .zip versions are also available, for testing without the need of installing them)

    best regards.


Log in to reply