User defined language: Font settings are not imported correctly anymore.



  • Dear all,

    I have created several user defined language files and exported them to xml.
    When I import them back, the defined fonts are no more set (font, size, …).
    Seems like here is something broken.
    Hopefully it gets fixed soon, because I work with them everyday.

    Thank you very much.



  • @fkl79675

    if you are on notepad++ version 7.6.6 or 7.7:

    • please remove your imported udl from the udl menu language > define your language.
    • then copy your exported udl xml file directly to %AppData%\Notepad++\userDefindeLangs\ instead of importing it.
    • next restart notepad++ and check uf your udl font settings are correct.

    please also have a look at >>> issue #5630 <<<, tested by @PeterJones , to see if it reflects exactly what you see.

    technical note: the udl handling has changed, to allow to have multiple udl files, instead of one single userDefineLang.xml file, containing all udls.
    this change could have caused this import issue with fonts, and one possible workaround, is to copy udl files directly to %AppData%\Notepad++\userDefindeLangs\ instead of importing them.

    a future idea for changing the udl import routine on newer versions, would be to simply do that copy job, instead of merging the udl to userDefineLang.xml, if this would solve the font issue.

    many thanks and best regards.



  • Thank you for the quick response.
    Yes, copy udl file to the mentioned folder (userDefineLangs -> without “d”) works. The fonts are shown correctly.
    Also yes, the mentioned Issue reflects my experience as well. I use the latest npp version.

    I would appreciate your work arround with copy job in a newer version.


Log in to reply