A bug when creating a new text file ?



  • Hi all.

    I am a new user of Notepad++. And very pleased with :)
    I am running windows seven x64 french version and I replaced the original notepad with notepad++ 7.7.7

    Yesterday I was browsing my harddisk and found an old text document that I named “adr mail (2017)”, with two spaces between “mail” and “(2017)”
    I tried to open it, but Notepad++ opened a window and gave me an error : “0” doesn’t exist. Create it?
    I first did not understand why this error occured but finally found it : Notepad++ does not like names with more than one space between words…
    I tried to create new text files with names like “new doc” or “45 7844”. Same error.
    And this also occurs with the previous version (7.6.6)

    Do you experiment the same bug ?
    Thank you for replies ;)



  • welcome to the notepad++ community, @Emric-Landuro

    i do not experience the same.
    opening a file with 2 consecutive spaces in its file name, like test 2 spaces.txt, works both if i open it from explorer with right click > edit with notepad++ and works via the notepad++ menu file > open.

    do both ways to open your file not work for you, or just one of them ?

    please also go to the notepad++ menu settings > preferences > default directory and make sure that use new style dialog is enabled, as seen at the screenshot below.

    Imgur

    best regards.



  • Thank you, Meta Chuh

    Sorry, I was wrong.

    After having experienced an (almost) same error with another prog, I restored my system
    and all is fine now.
    I don’t know what was wrong, and i don’t care… sometimes, PCs… hmm…



  • @Emric-Landuro

    many thanks for reporting back.

    I don’t know what was wrong, and i don’t care… sometimes, PCs… hmm…

    welcome to the club 😉

    best regards.


Log in to reply