Updated to v7.7. Run Menu no longer displays "Launch in ".



  • Updated to v7.7. Run Menu no longer displays "Launch in ". Downloaded v7.7 again and installed. Still no “Launch in …”



  • welcome to the notepad++ community, @dickm71

    yes, this menu entry was moved to view > view current file in > [browser name] as seen at the screenshot below.

    Imgur

    best regards.



  • Note also that the choices in the red box won’t be enabled unless you’ve saved to a real disk file.



  • Thank you. That did it.



  • Unfortunately all browser name is disabled in the View - “View Current File in” menu item, the browsers don’t start.
    I tried with more existing, old or freshly saved txt files on C: , D: hard drive, in the installed and portable version too.
    I have three versions of Firefox installed, Chrome is not installed, Edge and IE installed by default.
    The Launch in … and Send via … UserDefinedCommands are in comment.
    What could be the reason of this ?

    Notepad++ v7.7 (32-bit)
    Build time : May 19 2019 - 13:08:20
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : combine.dll ComparePlugin.dll DSpellCheck.dll HexEditor.dll LocationNavigate.dll mimeTools.dll NppBookmarkManager.dll NppCalc.dll NppConverter.dll NppExport.dll NppSaveAsAdmin.dll PluginManager.dll

    No change if I start with -noPlugin .

    Imgur



  • @László-Botka Because this option is configured on html files



  • @László-Botka Open the file shortcuts.xml and remove the comments of these lines. And then you can open your files in the browser through the menu “Run”

    	<UserDefinedCommands>
    		<!--
    		The following shortcuts are dangerous if your computer is compromised.
    		(But if your computer is compromised, EVERYTHING IS DANGEROUS!)
    		Remove the comment and use them at your own risk!!!
    
    		<Command name="Launch in Firefox" Ctrl="yes" Alt="yes" Shift="yes" Key="88">firefox &quot;$(FULL_CURRENT_PATH)&quot;</Command>
    		<Command name="Launch in IE" Ctrl="yes" Alt="yes" Shift="yes" Key="73">iexplore &quot;$(FULL_CURRENT_PATH)&quot;</Command>
    		<Command name="Launch in Chrome" Ctrl="yes" Alt="yes" Shift="yes" Key="82">chrome &quot;$(FULL_CURRENT_PATH)&quot;</Command>
    		<Command name="Launch in Safari" Ctrl="yes" Alt="yes" Shift="yes" Key="65">safari &quot;$(FULL_CURRENT_PATH)&quot;</Command>
    		<Command name="Send via Outlook" Ctrl="yes" Alt="yes" Shift="yes" Key="79">outlook /a &quot;$(FULL_CURRENT_PATH)&quot;</Command>
    		-->
    		<Command name="Get PHP help" Ctrl="no" Alt="yes" Shift="no" Key="112">http://www.php.net/$(CURRENT_WORD)</Command>
    		<Command name="Wikipedia Search" Ctrl="no" Alt="yes" Shift="no" Key="114">https://en.wikipedia.org/wiki/Special:Search?search=$(CURRENT_WORD)</Command>
    		<Command name="Open file in another instance" Ctrl="no" Alt="yes" Shift="no" Key="117">$(NPP_FULL_FILE_PATH) $(CURRENT_WORD) -nosession -multiInst</Command>
    	</UserDefinedCommands>
    	<PluginCommands />
    	<ScintillaKeys />
    </NotepadPlus>


  • @andrecool-68

    Thanks, good to know.



  • @andrecool-68 said:

    Because this option is configured on html files

    The files don’t have to be html for these options to be enabled. “Normal text” files, which the OP’s appears to be, will (or should!) open just fine in (for example) Chrome.



  • @Alan-Kilborn I agree that normal text files can also be opened via this menu.
    But why then @László Botka can not do this?
    Through the start menu, I can open files without restrictions … I personally like it more



  • @andrecool-68
    This is not a problem for me. Maybe somebody will tell sometime, why it doesn’t work. In the meantime, I wrote my own Run command for Firefox, because the built-in “Launch in Firefox” runs not the standard but the Nightly version, like the Windows 10 Run box, probably because it was installed last time. I only use Nightly for testing.



  • If I copy the .txt file with different extensions, the browsers are enabled and start for .cmd , .html , .xml , .c , but disabled for .txt , .zzz, .log , no extension.
    I don’t see what is the sense of this.
    I think if a file is open and npp can work with it, the view should work.
    The same issue exists on my wife’s Windows 8 machine.


Log in to reply