Compare Plugin v2.0 updated for Notepad 7.7 and above

  • Hi…

    Now in the Compare NavBar i have to move down each file at a time… to me it is pretty uncomfortable… is there any way ot make them behave like before to move both files down at the same time?


  • Hi @Pedro-David-Marco ,

    I’ll check and fix that, thanks.


  • @pnedev said:

    Hi @Pedro-David-Marco ,

    I’ll check and fix that, thanks.


    Thanks a lot !!! we look forward it…

  • Hi @Pedro-David-Marco ,

    I couldn’t reproduce the problem you experience.

    Could you confirm that your Notepad++ version is 7.7 and the Compare plugin is v2 from the link in my first post here?
    I suppose this is the case but let’s just be sure.

    Next, Please remove all your other plugins and try again. Tell me if the problem is still there.

    Thanks and BR

  • @pnedev

    Hi Pavel…

    Yes, both ar top versions… if i get back to older versions… it works properly again…

    I have reviewed all notepad++ settings just in case it is due to any new setting that causes the problem, not no luck… i still need to move both files one by one when comparing… i thought it was a new feature in compare :-(



  • Hi @Pedro-David-Marco ,

    Hm, really strange.

    Have you tried removing all your other plugins?


  • @pnedev said:

    Hi @Pedro-David-Marco ,

    Hm, really strange.

    Have you tried removing all your other plugins?


    Yes, i have tried it, no better luck…

    I have downgraded Notepad but not compare… (notepad++ 7.6.6 with Compare 2) and then Compare works ok. :-( so it must be something Notepad related…

    Any Notepad setting maybe?


  • @Pedro-David-Marco ,

    If you “downgrade” Notepad++ to version prior 7.7 you need to also use the “old” Compare v2.
    Compare v2 has two builds - one for Notepad++ 7.7 and above and another for Notepad++ version below 7.7.

    Please do not mix them.

    I really don’t know what might be causing this issue on your side.
    The last thing you could try is get a clean portable Notepad++ 7.7 64-bit and get this Compare build.

    If you try this please write what’s the result.

    Anyone else experiencing the same or similar issue?


  • @pnedev

    if I understand correctly issue is with scrolling both views, if so,
    no, is working fine here. Click on Navbar scrolls bot views and scrolling
    in an editor, scrolls the other as well. Noticed, that it seems to ignore the
    horizontal/verticals standard settings.

    Notepad++ v7.7 (64-bit)
    Build time : May 12 2019 - 01:26:14
    Path : D:\Tests\npp\770\x64\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 7 (64-bit)
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll NppExec.dll PythonScript.dll

  • @pnedev

    all good for me too on 7.7.
    both views are in sync.

    i’ve just tested it on notepad++ 7.7 x86 and x64, using and

    debug info:
    Notepad++ v7.7 (32-bit)
    Build time : May 19 2019 - 13:08:20
    Path : C:\Users\User\Desktop\npp.7.7.bin\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 7 (64-bit)
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll NppExport.dll

    Notepad++ v7.7 (64-bit)
    Build time : May 19 2019 - 13:05:35
    Path : C:\Users\User\Desktop\npp.7.7.bin.x64\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS : Windows 7 (64-bit)
    Plugins : ComparePlugin.dll mimeTools.dll NppConverter.dll

    best regards.

  • Same for me Notepad++ 7.7 64-bit with special Compare 2 for Notepad++ 7.7+, works fine!

    Agree with @Ekopalypse in that although scrolling works fine, looking at the N++ View menu, I see “Synchronize Horizontal Scrolling” checked and “Synchronize Vertical Scrolling” unchecked even though vertical scrolling is synced. Wonder if the special change you made is missing the MF_CHECKED update to put a checkmark at the appropriate menu item (since those seemed to have changed an shifted by one)?

  • @pnedev

    Hey Pavel… Good news!!! that build works!!! :-) thanks a lot! what was the problem? i am using normal notepad 7.7 and this new build…

    Thanks a lot for all your kindness and time…


  • Guys,
    Thank you all for testing.

    P.S. The Notepad++ vertical scroll (in the menu) should be disabled, that’s normal. Compare plugin does the vertical sync on its own.


  • @pnedev

    Compare is by far (to me) the best tool to compare important files…

    Thanks pavel!

  • I had the same issue about the views moving separately and what ending up fixing it is I had to manually move the dll into the compareplugin folder as by default it’s top level of the plugins folder.

  • Hi, @pnedev and All,

    • 10s to download your new build

    • 5s to create a new directory ComparePlugin, under my local configuration D:\@@\770\Plugins

    • 10s to extract the ComparePlugin.dll and the ComparePlugin folder inside this new directory

    • 5s to re-start Notepad v7.7.0

    • And, from now on, the privilege of using this must plugin, as your new build is OK, too, with my old Windows XP SP3 system :-))

    This post gives me the opportunity to talk about your future ComparePlus version, again ! Refer to the link, below :

    You said, at the end of this post :

    I’m still in the process of developing the smart change detection and I will try to make a good compromise between accuracy and compare speed.

    And I was wondering if, having a setting to choose between the Compare v2.0.0 and the Compare v3.0.0 behaviors of comparing, would make your coding phase easier ? Indeed, by doing so, you would not have to do any compromise, as you would propose the two native behaviors, just the old and the new ones !

    Of course, Pavel, just a suggestion :-))



  • Hi @guy038 ,

    That is actually a very good suggestion as it is difficult to find the “best” balance (because of the different compare cases) :)
    Thank you.


  • I’m a new user,so how to install this plugin?Thanks.

  • @汪Jerrie
    use plugins admin from plugin menu.

  • I recently updated to 7.7.1 (64-bit) and for me the synced scrolling broke too.

    In looking at the View Menu …

    Before starting a compare :-
    both Synchronize Vertical Scrolling and Synchronize Horizontal Scrolling are greyed out.

    When compare opens :-
    Synchronize Vertical Scrolling is UNCHECKED
    Synchronize Horizontal Scrolling is CHECKED
    Behaviour is consistent with these settings.

    Checking the Synchronize Vertical Scrolling option restores the pre-upgrade normal synchronized scrolling

    I cannot see any way to make that setting stick. If I evit Compare, and then restart it, the setting is lost.

Log in to reply