xml-tools plugin won't install



  • I am experiencing a problem with installing the iomportant xml-tools plugin.

    When I select the plugin and press Install, nothing happens and npp never restarts with plugin installed.

    Any suggestions?

    See screenshots
    https://www.dropbox.com/sh/pv0ikw1xaqwjpvx/AADUA1BLGAmXZUeCCjUBf40da?dl=0

    link text

    I am running winx64 on win10 (1809 release, upgraded from win7 in April).

    It might also be related to problem
    link text

    which is unresolved. Pls only comment if you think you have a solution - or know howto debug. I believe it is a general discussion issue and not plugin issue - as it is not a general problem but occurs on some win10 clients - with history - upgraded from win7 (ultimate x64)



  • Notepad++ v7.6.3 (32-bit)
    Build time : Jan 27 2019 - 17:20:30
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS : Windows 10 (64-bit)
    Plugins : DSpellCheck.dll mimeTools.dll NppConverter.dll NppExport.dll

    I tried to look for command line options/switches to install and debug options/switches - but could not find any examples and any attempt to learn by doing - just started the gui (application)… No support?

    C:\Program Files (x86)\Notepad++>".\notepad++.exe" -version



  • @Sverre-T ,

    Thank you for the debug information. It shows that the xmltools.dll did not end up in the correct directory (or didn’t properly download at all).

    This topic shows us helping another user through the installation of XML Tools. In that topic, @Meta-Chuh’s post shows a manual install.

    If you used Plugins Admin to do the install, and it failed, it was probably a proxy issue, as @meta-chuh explored in a post 2 below that and the subsequent conversation.

    I tried to look for command line options/switches

    Did you look in the help (?) menu, Command Line Arguments? Because that lists them all, with a brief description of what they do.

    There aren’t any options there that would have really helped you with the problem you were having, but for the future, that’s where to find it. The command line arguments are documented here (for now)



  • A million thanks. I successfully downloaded plugin and installed it following the instructions. I also noticed that there was an old “dangling” XMLtools dll on the plugin root directory - which I deleted - but that alone did not solve the gui plugin installation problem where npp never restarted and XMLtools never installed. See screenshots
    https://www.dropbox.com/sh/2srv89fdjeb53kt/AAC9tCPbjRMccnORZ1E5C9UOa?dl=0

    I add that I have installed the plugin on another client - which worked as expected - running on same platform and similar win7 upgrade.


Log in to reply