[New Plugin] ExtSettings

  • @dinkumoil yes that’s it. You perfectly got my point ;-)

    Are you on github ? Any chance that someone else can contribute ?

  • @cmeriaux

    The plugin is hosted at SoureForge in an SVN repository and is written with Delphi XE2. If you have an SourceForge account we can talk about collaboration. Another possibility would be to exchange *.patch files.

  • @dinkumoil said in [New Plugin] ExtSettings:

    Delphi XE2

    It would have been nice but I don’t know anything in Delphi XE2

  • This post is deleted!

  • @dinkumoil

    In Notepad++ v7.9.1 32-bit the settings are not being saved.

    Any chance of an update?

  • @Jeb-Dude

    In Notepad++ v7.9.1 32-bit the settings are not being saved.

    I’m not able to reproduce that with a portable v7.9.1 32 bit.

    Any chance of an update?

    It’s in the pipeline, but it may still take a while.

  • @dinkumoil ,

    I just had the strangest bug, that appears to be in (or at least affected) ExtSettings v1.2.1. The ExtSettings.ini file got corrupted to be all NULL bytes! I didn’t have a Notepad++ crash, so I’m not sure what could have caused that. And it seemed to happen in the middle of a Notepad++ editing session.

    Backstory and debug: I woke my computer this morning, and was working in a web editor in my browser.
    I think I had done selecting earlier this morning without difficulty, but I’m not 100% sure. But this time, when I went to copy some text from Notepad++ to my browser, and the selection highlighting was gone in Notepad++. I checked Style Configurator, which showed proper Selected text colour. Restarting Notepad++ didn’t fix it; rebooting didn’t fix it; I verified other apps still highlighted properly. Running a fresh portable unzip of Notepad++ didn’t have the problem – so I knew it was something specific to my normal instance of Notepad++. I temporarily renamed all my normal Notepad++ config files and restarted, to make sure that stylers.xml or something else hadn’t been corrupted, but still no highlighting. Disabled all my plugins, and the problem went away. Restored my normal config files with plugins disabled, and highlighting still worked. Enabled all the plugins and the problem returned, so confirmed it was a plugin problem of some sort. Enabling one at a time narrowed it down to highlighting stopped working when ExtSettings was loaded. I renamed ExtSettings.ini and restarted with ExtSettings enabled, and everything worked normally. I changed a setting in there (to force it to save a new ExtSettings.ini) and restarted, and it was still working. When I compared the renamed file to the new ini, I saw that the old/renamed version was 153 bytes of NULL, instead of 153 bytes of ini text.

    So it sounds similar to the old Notepad++ NULL bug, but it’s with the ExtSettings.ini file. I haven’t ever manually edited the ExtSettings.ini file directly in Notepad++, so I don’t think it was a problem with the editor directly. And I hadn’t recently made any changes to the ExtSettings through the plugin GUI, so I am not sure why it would have been trying to write/edit the INI yesterday or today. There has not been a recent crash of my OS or of Notepad++. I know that yesterday, I wasn’t having any difficulty selecting text, so the NULL corruption either happened while just in the course of normal Notepad++ editing this morning, or it happened when my computer went to sleep last night and/or when it woke up this morning. So, I unfortunately don’t have a repeatable circumstance for you to try to replicate the bug. (I know, I hate it when others report bugs without a repeatable circumstance.)

    @dinkumoil , When you create/open/write the INI file, are you using ‘CreateFile’ or similar API calls? If so, are you using the FILE_FLAG_WRITE_THROUGH to make sure it writes right away, rather than caching first? If you need help, I know that @pnedev is an expert on that now. :-)

    Notepad++ v7.9.2   (64-bit)
    Build time : Dec 31 2020 - 04:01:34
    Path : C:\usr\local\apps\notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 10 Enterprise (64-bit) 
    OS Version : 1903
    OS Build : 18362.1256
    Current ANSI codepage : 1252
    Plugins : ComparePlugin.dll ExtSettings.dll HexEditor.dll LuaScript.dll MarkdownViewerPlusPlus.dll mimeTools.dll NppConsole.dll NppConverter.dll NppEditorConfig.dll NppExec.dll NppExport.dll NppFTP.dll NppUISpy.dll PreviewHTML.dll PythonScript.dll QuickText.dll TagLEET.dll XMLTools.dll 

  • @PeterJones

    For writing the settings file I use a Delphi class that encapsulates the handling of INI files. AFAIK this class uses some Windows APIs for INI files (e.g. GetPrivateProfileString). Thus I don’t know if buffered write comes into play when the file is saved.

    The plugin’s INI file is written when its dialog is closed (the dialog’s window is destroyd as well in this moment). That means the last change of this file happened when you used the plugin for the last time. Thus, I have no clue what could have caused NUL-ing the INI file - especially as you wrote

    I hadn’t recently made any changes to the ExtSettings through the plugin GUI, so I am not sure why it would have been trying to write/edit the INI yesterday or today.

    Sorry, I have no idea how this could have happend and how to reproduce this incident.

  • I have an apparent compatibility problem with Notepad++ V8 and ExtSettings 1.2.1. The Vertical Lines settings are greyed out and the list is empty
    even though my ExtSettings.ini


    still has entries set up with Notepad++ 7.9.5.

    I also have 100 130 set in n++ own preferences, but when n++ starts, the lines are gone. If I re-enter 100 130 in preferences, they re-appear. If I open and close the ExtSettings dialog, they are gone again.

    If I enter just 100 in preferences WITHOUT background mode and open/close ExtSettings dialog, it changes from a line to background mode highlighting at 100.

    All was well in 7.9.5…

  • @astewart77

    Thank you for your bug report. I can confirm this is a bug. I will fix it when I have some spare time, but this can take a while. Due to dark mode related changes there are some other things to fix, too.

    For future bug reports: Please use the issue tracker of the plugin at SourceForge when possible.

  • @dinkumoil said in [New Plugin] ExtSettings:


    I will fix it when I have some spare time, but this can take a while.

    Probably just as well to wait for the dust to settle on v8 before bothering. ExtSettings is still a high value plugin even with a little breakage.

Log in to reply