Notepad++ 7.8, having issues with the save dialog



  • I used to be to hit N or Y without any other combination (ALT+N or ALT+Y) and be able to click to No and Yes, I cannot do it anymore
    Also I am not able to use Yes To all or No to all for some reason at all?
    Thank you

    70eee4bb-1974-41b7-9c67-8fa5b95b016d-image.png



  • @Gokhan-Varol

    See here.

    The reason the “to all” buttons are greyed out is that you probably didn’t invoke an “all” function; you likely chose Save rather than SaveAll.



  • You have brought up two very different issues.

    The first is regard keyboard accelerators: I can confirm that in 7.7.1, when you try to close new 3, you used to be able to hit Y or N to respond, and it would listen. In 7.8, it did not listen to me. (And @Alan-Kilborn’s citing of the issue#6223 shows it’s not just us.)

    The second is regarding Yes to all and No to all. My experiments show it is working correctly. If you have three edited unsaved files open, and you try to close just one (for example, new 3), then there is no “all”, there is just the “one”, so it doesn’t give you the options of Yes to all and No to all. If you use File > Close All or equivalent (including exiting Notepad++ with periodic backup disabled), it will enable the Yes to all and No to all, because there is more than one file to respond to.

    (Yes, I see this is mostly a detailed duplicate of @Alan-Kilborn’s post at this point. It wasn’t when I started, because he hadn’t posted yet.)


Log in to reply