Bug when using "themes" - font setting ignored on program launch.



  • Forgive me if this has already been reported, but I couldn’t find a ‘search’ function to search the forum…

    But there’s a bug when using a theme - the font of “Courier New” seems to get ignored upon startup. Notepad++ is defaulting to some halfway decent looking (but proportionally spaced) font, not what it’s set to in the profile (Courier New).

    However, switching to another theme, then back to Obsidian, it resets back to “Courier New”, - so it’s apparently not loading the specified theme font on startup.

    I was running v7.7.1 (32-bit), but just downloaded the latest (v7.8) and the bug exists there too.

    Thanks,

    Jeff



  • @JeffA-Maillists

    That’s weird. I used Obsidian for a long time until I recently came across TwoDark and never had a problem with it.
    Are you sure the progrmming language you’re using doesn’t use a different font within the theme?



  • @Ekopalypse I’m using ‘bash’, doing shell scripting.

    If I switch to any other theme, then back to Obsidian, it goes to Courier New, as configured.

    Again, NO changes made to theme attributes, just switching to a different theme, then back to Obsidian fixes it…

    Jeff



  • That’s really weird.
    Do you use installed npp or portable version?
    Depending on your installation I would give it a try to rename
    config.xml and see if recreation fixes this issue.
    Or if you use installed version, give a portable version a try.
    Just unzip it and run it.


Log in to reply