remove hyperlink



  • @cisco779k ,

    how many words…! I didn’t think it was that difficult…In my

    How could we know? You never showed us what your problem was, and your description of your problem was sketchy at best, and you wouldn’t respond to requests for more information. I had to make a guess as to what your problem was – and since toggling the option didn’t seem to be enough for you, and you said “text copied from an html page”, I guessed that you meant you had text like <a href="https://irueyrryrtytry.haj/">blah</a>; I now appear to have guessed wrong. But since you still haven’t actually showed us the problem you are having, I am still guessing.

    @Alan-Kilborn said in remove hyperlink:

    Double ugh.

    Indeed.

    I think the OP’s problem actually boiled down to “When I toggle that option, the underlining doesn’t appear to immediately change.”

    A quick experiment in my 7.8.2-64b, and I see that if I toggle that setting and hit Close button, it doesn’t immediately change. If I switch to a different tab in Notepad++ and go back, the underline goes away or comes back (whichever direction the setting was); in fact, if I page down and page back up, the underlining refreshes. Basically, a window-refresh needs to be initiated in order for that option to take effect.



  • @PeterJones said in remove hyperlink:

    in my 7.8.2-64b

    I just checked. The same was true in 7.7-64b or 7.5.9-64b, so this requires-refresh has been around for a while (maybe even always).



  • @PeterJones said:

    I think the OP’s problem actually boiled down to “When I toggle that option, the underlining doesn’t appear to immediately change.”

    But the OP said:

    uncheck No underlines then reboot notepad.

    Which leads me to believe the OP wasn’t bothered by a restart being needed, and something else was going on.

    But it is time to stop guessing and let this go…I’m out. :-)



  • dear PeterJones you guessed!
    I saved an html page on my pc, then i have clean all html code.
    before i had everything like <a href=“https://irueyrryrtytry.haj/”>blah</a>
    now i have delete all html code.
    my problem it is not underlining (which requires a restart np++ or refresh page)… this works! problem is persistence of the active link, on np++ while in simple notepad i don’t see…
    I didn’t want to post my screenshot because they are private data (those of the txt) but since my problem is perhaps not clear, i modified them and here i attach a screen: https://postimg.cc/0rHdTzH7



  • [sorry but I can’t insert a direct image here: when I click on insert image it comes ![alt text](image url) but insert url i don’t see on preview my image… then i have post url of my image]



  • and this also happens in a new document: perhaps it is the prerogative of np ++ to always show clickable links and perhaps this is possible only by disabling preferences.



  • all text, preceded by https:// or http://, is seen by np++ such as linkable.
    only way is disable from preference - MISC or delete https:// or http://



  • @cisco779k said in remove hyperlink:

    only way is disable from preference - MISC or delete https:// or http://

    Yes, that is the expected behavior. You either have to configure notepad++ to not underline links, or you have to make sure there are no links in the text; either one will stop notepad++ from underlining your text as a link.

    forum aside

    To help you with your difficulties in the forum:

    https://postimg.cc/0rHdTzH7
    [sorry but I can’t insert a direct image here: when I click on insert image it comes ![alt text](image url) but insert url i don’t see on preview my image… then i have post url of my image]

    That’s because the url https://postimg.cc/0rHdTzH7 doesn’t point to an image but to HTML, so ![](https://postimg.cc/0rHdTzH7) is trying to load an HTML page as an image, which doesn’t work. The actual image is at https://i.postimg.cc/Ghb7sYFg/345345345.jpg, so ![](https://i.postimg.cc/Ghb7sYFg/345345345.jpg) will display:



  • tanxs Peter, i understood my mistake in inserting an image.
    it will be very useful for the next posts!

    well, understood this little drawback, i hope that an option in np ++ is added which you deactivate text as a link for every single file, not just from preferences as a general rule…
    because maybe, in some cases, it may be useful to have a text as a link. if you disable it from preferences, it will never occur again!
    it would be convenient to be able to select link and with the right button to have an item such as “view link as plain text” in the menu in order to have a choice of each link …
    this is what i would like in a nest future version of np++



  • I said “I’m out” but I had to come back for one more comment: This whole thread is ridiculous.

    It’s just text. If you leave the underlines on, just ignore them. If you don’t want to follow the links, don’t double click them. It’s THAT simple.

    well, understood this little drawback, i hope that an option in np ++ is added which you deactivate text as a link for every single file, not just from preferences as a general rule…because maybe, in some cases, it may be useful to have a text as a link. if you disable it from preferences, it will never occur again! it would be convenient to be able to select link and with the right button to have an item such as “view link as plain text” in the menu in order to have a choice of each link …this is what i would like in a nest future version of np++

    None of that stuff is ever going to happen.



  • Hello, @cisco779k

    Please follow these steps to remove hyperlink.

    Step 1:- Open Notepad++ and go to Settings.
    Step 2:- Select Preferences.
    Step 3:- After opening preferences window, Click on MISC tab.
    Step 4:- Click under the ‘Clickable Link Settings’ section in uncheck the ‘Enable’ checkbox.

    392f7785-1343-4e1c-b7e4-c79925e6f6d0-image.png

    I hope above information will be useful for you.
    Thank you.



  • 2021-02-18_3-11-36.png

    Step 1: - Open Notepad++ and go to Settings.
    Step 2: - Select Preferences.
    Step 3: - After opening preferences window, Click on ‘Cloud & Link’ tab.
    Step 4: - Click under the ‘Clickable Link Settings’ section in uncheck the ‘Enable’ checkbox.



  • @Lê-Thanh-Bảo said in remove hyperlink:

    2021-02-18_3-11-36.png

    Step 1: - Open Notepad++ and go to Settings.
    Step 2: - Select Preferences.
    Step 3: - After opening preferences window, Click on ‘Cloud & Link’ tab.
    Step 4: - Click under the ‘Clickable Link Settings’ section in uncheck the ‘Enable’ checkbox.

    YES! This saved my butt. How would they even consider moving this setting to such a strange and unlogical place?
    Thanks for the tip!



  • @Vincent-Koevoets said in remove hyperlink:

    How would they even consider moving this setting to such a strange and unlogical place?

    Hmmm, “strange and illogical”, hmm.
    I think you must be trolling because this is a very oddball statement.
    The Preferences category name is Cloud & Link.
    Not sure where else one would look for “link” settings.
    I mean, it used to be under MISC. and that is less specific.



  • I came across these post looking for the same solution as the OP. However, it became clear that everyone was trying to talk over each others’ heads and not addressing the issue. Therefore, I will do my best to explain what is happening and what would be the ideal results.

    First, let’s all agree that what is displayed in Notepad++ is NOT “plain” text. If it was simply “plain” text, any text that follows the format of a URL would not appear to a hyperlink.

    e3d8a330-17dc-47a8-8abc-66b0972c66da-image.png

    Yes, we could argue that it is really “plain” text and it only appears to not be “plain” text because Notepad++ draws the underline and changes the mouse cursor to look like a clickable hyperlink when you hover the mouse over it. The point is that it appears to be a clickable link and that is not what is expected from a “plain” text editor. Plus it can distract the person from clicking on it.

    For example, if I just want to click and highlight a portion of the string of text, I might be reluctant to click anywhere on it expecting it to open up the hyperlink in my browser. Alas, it doesn’t follow the link unless you double click on it.

    dda9aa8f-3e16-4927-afc9-31b881eac2e1-image.png

    I have to admit that at first I was reluctant to click anywhere on the “link” in fear of it taking me to my browser when all I wanted to do was copy a portion of the URL.

    If you can get past the point that simply clicking anywhere on the “link” is not going to take you away from what you are intending to do, then it is a mute point if you decide to uncheck the box for Settings->Preferences->No Underline. You simply treat the text as “plain” text and ignore that it looks like a hyperlink.

    For those that can’t get past the fact that it looks like a hyperlink, then uncheck the fore mention check box. Yes, at first I was unable to get past this fact and treat it as plain text when it was telling my brain that it wasn’t.

    It only becomes a true hyperlink if you double click on it. If this was not the case, I can see why it would be necessary to have hyperlinks for those documents that you want hyperlinks and no hyperlinks for those you don’t.

    You may ask, why did I even bother to bring this up when it is so obvious. The point is that it is not obvious to everyone, including myself at first. I have found that it is not always best to approach answering a question assuming that the person asking the question has the same knowledge that you do; otherwise, why even ask the question in the first place. For those asking the question, it is best not to assume that everyone understands your problem and can read your mind. I only understood your question, because I came to this post looking for the same answer.

    I learned that I needed to accept that my mind is playing tricks on me and that it is really not a hyperlink. So, I will leave by quoting The Matrix, “There is no spoon”.



  • @Cruce said in remove hyperlink:

    It only becomes a true hyperlink if you double click on it.

    Correction. As it wouldn’t let me edit what I posted above.

    “It only behaves like a true hyperlink, if you double click on it.”



  • @Cruce

    I will do my best to explain … what would be the ideal results

    Unless I missed it, I don’t think you explained what the “ideal results” would be. I suppose I can infer that your ideal is to never have any underlined text – but that would bother the productive text editor users that exploit this feature to increase their, well, productivity. I recently discussed how to exploit this feature for even more productivity in another thread.

    it appears to be a clickable link and that is not what is expected from a “plain” text editor

    So maybe the ideal results you mention would be not showing this type of text as underlined, thus falling behind in capability other text editors to do show this type of thing.

    everyone was trying to talk over each others’ heads

    I’m probably guilty of doing this again, if I was guilty of it the first time.

    at first I was reluctant to click anywhere on the “link” in fear of it taking me to my browser

    And OMG that would be the biggest travesty of all time, to have that happen.
    On the contrary, if that did happen, at least you’d learn something about the software you’re using.

    I learned that I needed to accept that my mind is playing tricks on me and that it is really not a hyperlink

    Why can’t it be both text AND a hyperlink?
    What is the big objection here?
    And sure, turn it off if you like (and lose functionality).

    You may ask, why did I even bother to bring this up when it is so obvious.

    Yep.

    And for things that are not obvious, sometimes you have to do something called “playing with the software”, so you understand how it works. Do this and you’ll move to a higher plane of awareness, so that you can work better in the future. Don’t do it and you’ll stagnate, until, like an elderly parent, you’re afraid to even try to open a .PDF

    Again I say This whole thread is ridiculous.



  • I don’t like this, because I think it just adds noise, but some programs, most notable in my mind being Microsoft products, pop up a box like this when link text is hovered, explaining what you can do:

    1f2f894b-10e1-45b7-8865-61541fe13524-image.png

    Again, I’m not a big fan of this, but perhaps this is what people are looking for, so the possible action is detailed.

    Screenshot from Microsoft Visual Studio.


Log in to reply