Trouble saving files with .js extension:



  • After installing latest 64 bit version I cannot save a text file or even one with a .js extension. The only choice is an all files type. The 32 bit version on my laptop works fine???



  • @Terrell-Miller

    Try this:

    Create a new file and put some data in it so it is “saveable”.
    Press Save button on toolbar (or File > Save or ctrl+s).
    Type exactly this in the dialog that pops up: test.js <-----key point
    Press Enter.
    Did your test.js file get created (with the .js extension)?



  • Yes it worked. Is this a new feature that I need to follow for html files as well?



  • @Terrell-Miller

    I call it the “just type the damn dot and the extension” feature. :-)

    However, if you can endure the other (negative IMO) aspects of it, you can also untick the Use new style dialog... choice in Settings > Preferences > Default Directory and after doing that, when the same Save box comes up in that situation, you can simply type test (instead of test.js) in the box and press Enter to save it.

    (Hopefully you can see the answer to your html part of your response)



  • thank you very much. I’ll probably take the lazy way out. But this is a relief that the new save procedure is a feature that changed that I did not pick up on.


Log in to reply