Format different in regular notepad after installin notepad++ HELP!



  • Hello,
    I recently installed notepad++ and I really like it. I have no issues with notepad it self. The problem is that it seem to have change some kind of setting that I need reset. IDK how familiar anyone is here with excel but there is this kind of “tirck” if you will, where you copy and paste the formulas of entire rows or columns, and paste them into notepad. from there you can copy again, and paste them into another excel workbook and it keeps the exact formulas without ANY changes into the same rows/columns. This is helpful because if you copied the forumulas from one workbook to another, the references will be linked back to the source workbook.

    The problem is that now notepad no longer keep the same (excuse my lack of technical term) spacing. what once used to be in the same continious line now is now staggard. which is definetly much much easier to read BUT it prevents me from copying to excel correctly.

    I tested notepad in another computer thinking notepad had recently received an update or something. Well the other computer has no issues. I decided to email me the notepad file and when I opened it in my pc, it had changed “format” into the type that I cant copy into excel. it seems to be the way im viewing the file because it only looks diferent in my pc…odd

    If you guys could help me get back the old format or find a notepad app that hard forces this please. I tried like 2 other notepad apps and they have the same problem



  • @Union-Express ,

    it’s a little confusing what’s going wrong for you.

    When you copy from Excel and paste into any plaintext application (like Notepad++), it will paste as tab-separated values. Even if you have Settings > preferences > Tab Settings > Default > Replace by space enabled, they will be tab characters. You can see this if you turn on Notepad++'s View > Show Symbol > Show Whitespace and TAB feature.

    Original spreadsheet:
    1b3e6c81-eaeb-47d3-9983-0d1fb8f341c7-image.png

    Copy/paste into Notepad++ with Show Whitespace and TAB enabled:
    0e3393f4-0dc0-4b50-bac9-8932c403f6a0-image.png
    (those arrows indicate the tabs)

    Copy/paste from there into a new location in a spreadsheet:
    6b0ff042-613a-469c-a253-9d7cf8277b01-image.png

    So, since “it works for me”, you’ll need to provide more information. I’d recommend using either Alt+PrintScreen to copy images of whole windows and Ctrl+V to paste them in your response, or use the Microsoft Snipping Tool (or their new replacement Snip & Sketch) to grab portions of the windows, like I did.

    (Caveat: at home, I use OpenOffice Calc, not Excel; but the copy/paste functions the same between those two apps. I copy/paste from Excel to Notepad++ on occasion at work, and have never had a difficulty like you’re describing, though since I’m home for the weekend, I obviously cannot show you screenshots of it working there.)



  • Thank you for the reply!
    I can confirm that NPP works the same on my pc from the example you gave.
    Just to clarify the OP, I only have issues copying the formulas and I am copying them by first enableing Formulas > Show Formulas. Without it enabled, you can only copy the product of the formula.

    In the example below, you will probably notice that I am formating the formula so it can be easily read/understood instead of it all being in one line. I can confirm that on other PCs, this is not an issue (see 3rd picture)

    Excel

    This is how the above gets pasted into NPP. as you can see, it keeps the same formatting as in the formula bar in excel
    cf3e480c-aa69-4023-b4d3-34a7cee86161-image.png

    Here is the same exact file pasted into notepad but from a different computer
    35bd4fb6-5c60-4031-a80f-41a89ad58d86-image.png

    Here is that exact prior notepad file opened in my pc:

    7adda84f-35fd-45f1-aeb6-09cb6b177ba8-image.png

    You might be asking yourself, why would someone need this capablility. Well if I was to copy the fourmulas directly from one workbook to another, the fourmulas will be linked to the source workbook. so A4 is now [sourceworkbook]sheetnumber!A4.

    any help is apreciated!



  • This post is deleted!


  • Follow up,
    I do not know if anything has changed on my pc (i havnet done anything different) but now my formulas are pasting. I thought perhaps it was because I enabled Settings > preferences > Tab Settings > Default > Replace by space but I tested it with it disabled and it is still pasting in the correct cell. perhaps it was a fluke and my pc restarted and the issue went away, or I was just doing something wrong.

    However, it is till behaving differently than when copy/pasting in another pc with regular notepad.
    Normal behavior on another PC: with Formulas > Show Formulas enabled. Copying from source workbook to notepad then copying to new workbook, the formula will be “live” (unsure how to say) meaning it will be computing as soon as you paste them.

    Behavior in my pc. when pasting to the new workbook, the formula seems to paste correctly but it is not automatically computing. to enable it, I click the formula bar to begin editing and then without making any changes I press enter. now the formula is live

    I do apologize for not being able to explan the sudden change of pasting behaviour which was the original issue I had. im sure it can be fustrating to help someone like this :/



  • I am at a machine with Excel now.

    If I take a couple of simple formulas – where row 1 has no newlines in the formula, but row2 has newlines:

    75ccd2d2-5a8c-4e55-bcd5-25942ed5b144-image.png

    and paste into notepad++, with View > Show Symbols > Show All Characters:
    70c583d1-9383-4c2b-9a45-cf81bb92ad86-image.png

    if I select all that from Notepad++, and paste into a new sheet in Excel, I get:
    5656eaa7-8e82-4013-82b8-d3d0d7983ac5-image.png
    but when I don’t show formulas, I see that Excel actually treated the multiline formula as text:
    2e5249a5-8efb-460b-a42f-266c1af64b9e-image.png

    Unfortuantely, because you didn’t show spaces-and-tabs, like I described in my first response, and you didn’t show all-characters (which might help with newlines, in case that’s influencing things), it’s hard to tell what’s different in the screenshots you showed.

    When I try the same experiment, but use the ms windows’s notepad.exe as the intermediary instead of Notepad++, it does the same thing. Which means the problem is not something specific to Notepad++, but is completely up to Excel.

    My guess is that you have some setting or version different in Excel between the two machines. But since it does the same thing for me, whether I use Notepad++ or notepad.exe for the intermediate step, it’s not a Notepad+±specific problem, and not really something where we can be expected to have expertise.

    (My screenshots today are from an active-subscription Office365 ProPlus Excel: ee1ee13a-7735-4873-9b49-cf8df251c86a-image.png

    To be helpful: if I copy from one workbook to another, starting with:
    d695f675-de34-470a-b90e-e8c0943b0ae9-image.png
    and pasting, to get:
    38c61a77-a696-4734-9f16-1ff524bfa033-image.png

    I get all the right formulas, without prefixing with [sourceworkbook] name.

    So, you seem to have differences in two versions of Excel, and Excel settings in such a way that the source name is copying. I cannot explore different Excel settings for you, but can confirm that with the way mine is set up, copying from one workbook to another doesn’t make it link the data: the formula stays local to the workbook.

    These are Excel problems, not something specific to Notepad++, so from here on out, you should probably move to an Excel forum. You should probably ask one or two questions – which are separate ideas, though the second isn’t as important now that you know that Excel should be able to handle the copy/paste with formulas correctly.

    1. The first question would be worded something like “when I copy formulas from one workbook to another, for me it inserts the source workbook name into the destination formula, so it creates a link between the workbooks, but I am wanting to copy the formulas to the new workbook so that the formulas are relative to the new workbook. (And when I asked a similar question in a wrong forum, I was told that in circumstances of someone over there, Excel didn’t make the formulas a link, and did what I expected. Could you help me figure out how to make the pasted formulas reference the cells in the new workbook, rather than be formulas with links to the old workbook for the data?” You could include screenshots similar to above, but showing how the formulas don’t work right.

    2. If you really needed to know why the thru-text-editor didn’t work, you could also ask, “Second, why when I Formulas > Show Formulas, and copy/paste the formulas into a text editor like notepad.exe or Notepad++, and then copy/paste from the text editor into a new Excel workbook, why does a multi-line formula first get interpreted as text, until I F2-edit then hit enter, when Excel properly treats it as a formula again?”

    But again, this is all stuff for the Excel forum of your choice.



  • @PeterJones said in Format different in regular notepad after installin notepad++ HELP!:

    ttings in such a way that the source name is copying. I cannot explore different Excel settings for you, but can confirm that with the way mine is set up, copying from one workbook to another doesn’t make it link the data: the formula stays local to the workbook.
    These are Excel problems, not something specific to Notepad++, so from here on out, you should probably move to an Excel forum. You should probably ask one or two questions – which are separate ideas, though the second isn’t as important now that you know that Excel should be able to handle the copy/paste with formulas correctly.

    The first question would be worded something like “when I copy formulas from one workbook to another, for me it inserts the source workbook name into the destination formula, so it creates a link between the workbooks, but I am wanting to copy the formulas to the new workbook so that the formulas are relative to the new workbook. (And when I asked a similar question in a wrong forum, I was told that in circumstances of someone over there, Excel didn’t make the formulas a link, and did what I expected. Could you help me figure out how to make the pasted formulas reference the cells in the new workbook, rather than be formulas with links to the old workbook for the data?” You could include screenshots similar to above, but showing how the formulas don’t work right.

    If you really needed to know why the thru-text-editor didn’t work, you could also ask, “Second, why when I Formulas > Show Formulas, and copy/paste the formulas into a text editor like notepad.exe or Notepad++, and then copy/paste from the text editor into a new Excel workbook, why does a multi-line formula first get interpreted as text, until I F2-edit then hit enter, when Excel properly treats it as a formula again?”

    But again, this is all stuff for the Excel forum of your choice.

    I completly understand not going far into excel, this is a notepad++ forum after all. thanks for thaking the time to look into this! I will look further in the excel forums. ill be back if anything points back to N++ but youre probably right and its to do with excel. Thansk again Peter!


Log in to reply