Notepad++ 7.5.4 (64-bit) slow working with large files (solved)



  • Basically what was happening to me was that when I had large files open (20MB +) and tried typing in them it was taking forever to actually print the text to the screen. What looked to be many outlines of small boxes were visible during the delay, which was the tip off.

    I experienced no slowness opening, or saving the file.

    I was able to solve the problem by disabling auto complete! (I guess every letter or word was being referenced against an autocomplete that was just killing the processing) Settings --> Preferences --> Auto-Completion : Uncheck “Enable auto-completion on each input” and possibly “Function parameters hint on input” for good measure (I did).

    I admittedly do not have the latest version of notepad++ so this may have been fixed in later releases. It can be replicated by simply opening a large text file (mine are 20 - 75 mb or so) and trying to type into an available row. The type of text file may be relevant as well in regards to how auto-complete processes it.

    Hopefully this will be of benefit to someone.



  • @jack4455667788 said in Notepad++ 7.5.4 (64-bit) slow working with large files (solved):

    this may have been fixed in later releases

    How does one “fix” this? Autocomplete is a feature, if it is turned on it will attempt to do its work as best it can. In some scenarios, it isn’t going to be optimal.


Log in to reply