Disable autodetect syntax by content



  • I have issues with files [.wsc]
    Usually its VB or ASP language, but .wsc file has xml like format and VB coding in the body.
    Editor use autodetect <?xml version=“1.0”?> line in the beginning and made autoswitching to XML syntax.
    After changing Language to VB from menu - Editor again will switching to XML after using Tab between files.

    For now - impossible to work with .wsc files in VB or others syntax. Editor everytime will switch to XML



  • @Ihor-Laputin

    Editor again will switching to XML after using Tab between files.

    Does not happen to me, what npp version are you using?
    Can be seen in debug-info from ? menu.
    What about using Style Configurator, selecting VB/VBS from Language and adding wsc to the User ext.: section?



  • @Ekopalypse said in Disable autodetect syntax by content:

    Does not happen to me

    Are you sure you replicated @Ihor-Laputin 's conditions? Because it happened for me at home last night (and since I didn’t have a solution, I didn’t post then), and it happens at work for me this morning.

    I googled for “example wsc file”, and grabbed the example from this SO post. Using that file (saved as test.wsc), I get exactly the behavior described.

    Here’s an animated screenshot:

    At home, I had tried defining .wsc for a UDL, instead, with the same results. It seems that there’s some autodetect based on the content of <?xml version="1.0"?> that overrides the by-extension lexer definition, at least from what I can see and from what the OP describes.



  • @PeterJones

    I used the same source you did



  • I see 7.8.5 on the your screen.
    For me - issues with .wsc files happened om all version till 7.8.4.
    The same as on the presentation from @PeterJones




  • @Ekopalypse maybe something with the Settings in Preferences? maybe there is checkbox that can disable autodetect while switching between Tabs?



  • I found additional info.
    This is not related to WSC extension.
    The same happened with [New] file w/o saving - on the switch between Tabs will be same.
    For repeat:

    • create 2 new tabs w/o saving
    • place <?xml version=“1.0”?> content into first Tab
    • switch to VB language
    • switch between Tabs
    • its again xml language switched

    how disable in the options - auto choosing syntax?



  • @Ekopalypse ,

    I just tried a fresh portable 7.8.5 RC1 and it matched your experience rather than my previous experience.

    Weird. A fresh portable 7.8.4 also matched your experience. But if I go back to my customized 7.8.4 portable (which I normally use), then it shows what Ihor and I have been seeing.

    There must be a setting or plugin that’s causing this discrepancy. I’ll do some more investigation and post again later.



  • My workhorse is 7.8.2 and it doesn’t happen.
    @Ihor-Laputin - I’m not aware that any of the settings is dedicated to this
    but maybe a combination of different settings or a side effect of one setting is responsible for our different behavior.

    @PeterJones - if it is a plugin, then it might XMLTools, I will give it a try
    on my side as well.



  • Yes, if XMLTools is used and the option Set XML type automatically is set, then this happens.
    @Ihor-Laputin , do you use XMLTools plugin?



  • @PeterJones YES! Man - its was good idea about plugin!!!
    When you say plugin… I am going to check plugins that I have installed, and found [XML Tool 2.4.11]
    that has has few settings. Only one option made this issues [Set XML type automatically] when this options is disabled - issue with autoswitching fixed.
    Big thanks @PeterJones ))))



  • Well, I was working on confirming that disabling XML Tools worked for me when @Ekopalypse posted. Then I was working on confirming that disabling Set XML type automatically worked for me when @Ihor-Laputin posted.

    I will just say “yep, those fixes work for me, too”, rather than all the details that used to be in this post-in-progress. :-)



  • I am use XML tools everytime and in this case have this issues with WCS files few years as min.
    Few years I have a problem with this and everyday used “Alt+L , V” … every day … few years… maybe I am crazy… I checked Editor settings a 1000 times …
    … now I am FREEEEeeeeee … ))) I need to drink. Thanks a lot to all … today my new HB day ))))



  • :-D
    :-D


Log in to reply