Slow to reload in larger files



  • I have text files that are very slow to reload from disk. They are text files, and once I hit about 10,000 lines of text, reloading is very, very slow. I have looked for answers, and no suggestions are speeding the reloads up. It is becoming unusable.

    1. These files are added to regularly - they are log files.
    2. I am using my own defined language for highlighting some text.
    3. The files are never over 10 MB.
    4. No plugins installed, except the JSON viewer.
    5. I have auto-reload to updated the document. However, I have the same slowness even if that is turned off.
    6. Back up if off.
    7. Auto completion is off.
    8. Work wrap is off.
    9. I am on the current version 7.8.4

    Thanks
    Kelly



  • @Kelly-Hoke

    maybe make a simple test.
    Assign the text lexer, which basically means no lexer at all, to the document
    by selecting language->N->Normal Text and then try to reload
    the file. Is it still slow?
    If so, please post the your full debug-info from ? menu.



  • Reverting back to Normal Text resolved the issue. Thank you for your quick response.



  • @Kelly-Hoke

    that would indicate that the lexer, which was active, isn’t capable of
    lexing the document fast enough. Was this an udl or a standard lexer?


Log in to reply