"Find" box grayed out.



  • What did I do? I was using it for a bunch of changes and perhaps I hit something but now the box is grayed out. Everything still works it is just damned hard to see. I reloaded notepad and it has been several days but I don’t have any idea how to fix it. any help would be appreciated.



  • Hi @chilkoot,

    It looks as if the transparency of the Find window were set to 0, or a value close to it.

    At the bottom right corner of the Find window there is a section on Transparency. Try to adjust the settings there, moving the control to the right. Or try to disable the Transparency checkbox, just below the Close button.

    Hope this helps.



  • I used to think Transparency was of dubious usefulness. Then it occurred to me that it is totally useful in the following circumstance: When using Notepad++ on a single monitor system. Of course in this setup one runs Notepad++ maximized (right?) and the Find window (being so large!) just gets in the way.

    Enabling Transparency and setting a very low level and moving the Find window to the lowest and rightmost position possible makes for a very workable situation: It’s there and easily activatable when needed, but doesn’t obscure anything else.

    I guess this is the original point of the Transparency settings, but it took me a while to “come around” to really finding a use for it. I must admit that I don’t use a single monitor setup very often (normally I have the Notepad++ main window maximized on one monitor and the Find window in the upper right of the monitor immediately to the left.

    Of course, I personally still don’t have a use to enable the Always option!



  • @Alan-Kilborn said in "Find" box grayed out.:

    Then it occurred to me that it is totally useful in the following circumstance: When using Notepad++ on a single monitor system. Of course in this setup one runs Notepad++ maximized (right?) and the Find window (being so large!) just gets in the way.
    Enabling Transparency and setting a very low level and moving the Find window to the lowest and rightmost position possible makes for a very workable situation: It’s there and easily activatable when needed, but doesn’t obscure anything else.

    You have described with great accuracy my situation — a too big window for a not so large screen— and workarounds to deal with it.

    There is only one thing missing - the script with which I adjust the transparency or opacity of the Find window, which when it is opened, almost always lurks in the low right corner at 25 percent.

    I’ve learned to live with this setup.



  • @astrosofista said in "Find" box grayed out.:

    There is only one thing missing - the script which I adjust…

    Yes, I have a script as well. It checks the number of monitors and then does the appropriate thing. The script is a bit involved so I won’t post it here.



  • @Alan-Kilborn said in "Find" box grayed out.:

    checks the number of monitors

    A multi-monitor playground, that’s quite cool. I would be lost there…

    In my case and due to lack of working space I have no choice but to work simultaneously with many open tabs - usually I have around a hundred tabs in use.

    If you ever want to feel a touch of claustrophobia, given a small screen, open the Dock Switcher and do either a search on all open documents or open the Python console. I guess you will get that feeling.



  • @astrosofista said in "Find" box grayed out.:

    There is only one thing missing - the script with which I adjust the transparency or opacity of the Find window, which when it is opened, almost always lurks in the low right corner at 25 percent.

    Doesn’t it keep its setting? It does for me.
    Or are you looking for some kind of
    if find_dialog_has_focus then opacity=100 else opacity=25?



  • @Ekopalypse said in "Find" box grayed out.:

    Or are you looking for some kind of
    if find_dialog_has_focus then opacity=100 else opacity=25?

    Something like that, and solved it via an AutoHotkey script. Not a big deal, but can post it if anyone is interested.



  • @astrosofista How did I miss that?? Thanks, seems to have resolved problem. thanks so much, it has been driving me nuts.



  • @chilkoot

    Great! It is good to hear that it worked for you.

    Best Regards.


Log in to reply