Notepad++ v7.8.6 Release Candidate 2



  • Here is 7.8.6 Release Candidate the 2nd try:
    http://download.notepad-plus-plus.org/repository/7.x/786rc2/

    Notepad++ v7.8.6 Enhancement & bug-fixes:

    1. Add multi-column marker (multi-line edge) feature.
    2. Add dynamical sorting feature for Folder as Workspace.
    3. Make MRU tab activate instead of rightmost tab while tab closure (if MRU enabled).
    4. Fix folding state lost on the next startup issue.
    5. Make Replace-in-Files confirmation dialog modal to prevent from crashing.
    6. Add support of smart-indenting for Perl and Rust.
    7. Make recorded macro (IDC_FINDNEXT & IDC_FINDPREV)retro-compatible up to 7.8.4.

    The difference from RC to RC2 is the UI is simplied to fix the reported bug:
    https://community.notepad-plus-plus.org/topic/19232/notepad-v7-8-6-release-candidate?_=1587163402847

    Please let me know if you find any regression or critical bug.



  • Hello, @don-ho and All,

    I’ve just downloaded this last release and the new Vertical Edge Setting is more simple. Nice !

    I noticed, of course, that, as soon as you add more than one number, the Background mode is then grayed out

    However, when you stop and restart Notepad++, immediately, the Background mode option is still available, although it contains several numbers ?!

    To my mind, it would be better if the Background mode option was always available. Let me explain :

    If more than one number is indicated AND if the Background mode option is ticked, Notepad++ would choose to highlight from the largest column number ( or the smallest, it’s up to you ! )

    What’s your feelings, about it, Don ?

    Best Regards,

    guy038



  • @guy038 said in Notepad++ v7.8.6 Release Candidate 2:

    I noticed, of course, that, as soon as you add more than one number, the Background mode is then grayed out
    However, when you stop and restart Notepad++, immediately, the Background mode option is still available, although it contains several numbers ?!

    Hi Guy. Thank you for your test.
    I can’t, however, reproduce the problem you described. Could you provide the step-by-step instructions?

    To my mind, it would be better if the Background mode option was always available. Let me explain : If more than one number is indicated AND if the Background mode option is ticked, Notepad++ would choose to highlight from the largest column number ( or the smallest, it’s up to you ! )

    I wish I could do it, but Scintilla doesn’t allow such situation - background mode is only for single edge mode.



  • @donho said in Notepad++ v7.8.6 Release Candidate 2:

    Could you provide the step-by-step instructions?

    I can:

    • Background mode unticked
    • Add single number 3 to the big box
    • Add space and 9 to the big box (Background mode immediately goes “disabled”)
    • Restart N++ 7.8.6 RC2
    • Observe 3 9 in the big box, with Background mode showing as “enabled”
    • Add a space after the 9; observe Background mode immediately goes “disabled”

    I guess it is “okay” but it feels a little klunky. In fact, the very first version, in RC1, seems better at this point. Not meant to be an insult; it is great to have this feature no matter what. :-)

    Scintilla doesn’t allow such situation - background mode is only for single edge mode.

    I’m confused, because nobody is asking for that.



  • @guy038 @Alan-Kilborn

    OK, I can reproduce it now.
    It’ll be fixed in RC3 - Thank you!



  • Hi, @Don-Ho and All,

    Sure I can, no problem ! So :

    • Open N++ v7.8.6 RC2

    • Go to Settings > Preferences... > Editing > Vertical Edge Settings

    • Write only 1 number in the columns zone => As expected, the Background mode is available

    • Now, add a 2nd number => As expected, this time, the Background mode option became grayed out, as soon as you typed in the first digit of the second number

    • Close the Preferences dialog and, immediately, re-open it ( Settings > Preferences... > Editing ) => OK : As two numbers are indicated, the Background mode option is still grayed out

    • Now, simply, stops and restart N++ v7.8.6 RC2

    • Go to the Settings > Preferences... > Editing dialog => Now, althougth the two numbers are present, the Background mode option is, again, available


    Don, note that this behaviour could occur because of my WinXP configuration and/or because I’m using a portable version ?

    Cheers,

    guy038



  • Hi, @don-ho, @alan-kilborn and All,

    Regarding the Vertical Edge Settings, @alan-kilborn said :

    I’m confused, because nobody is asking for that.

    Maybe, I didn’t make myself clear ! Of course, I completely understand that background mode works with one vertical edge only !

    But I thought that, by coding, in case of the Background mode option is ticked, N++ would always consider the rightmost indicated number only ;-))

    Best Regards,

    guy038



  • @guy038 said in Notepad++ v7.8.6 Release Candidate 2:

    But I thought that, by coding, in case of the Background mode option is ticked, N++ would always consider the rightmost indicated number only ;-))

    OK, I see.
    I personally don’t like this behaviour because it could (not only) hide multi-edge line feature if it’s checked, and (but also) make user confused.




Log in to reply