Add Notepad++ to "How do I open this file?" dialog please...



  • I often want to use Notepad++ to open files with new, random extensions that I know are really text files. Unfortunately Notepad++ doesn’t come up by default in the Windows “How do I open this file? dialog”.

    I have fixed this on my PC by adding the registry info with the following command:

    reg add HKCR\Applications\Notepad++\shell\open\command /ve /t REG_MULTI_SZ /f /d "\"^%ProgramFiles^%\Notepad++\notepad++.exe\" \"%1\""
    

    Can you please consider adding this to the default installer? Seems like a useful add for anyone…



  • So what is wrong with the “Open in Notepad++” Context Menu Extension?



  • @Scott-Sanders,

    Because you showed %ProgramFiles%\Notepad++ as your path, I am going to assume you have the 64-bit Notepad++ in a 64-bit Windows OS.

    So when you installed, you didn’t get HKCR\*\shellex\ContextMenuHandlers\ANotepad++64,
    which directs to HKCR\CLSID\{...}\, which points to Notepad++.exe’s installed location? Because that’s what the installer tries to do, in my experience. And that should set up the Edit with Notepad++ right-click entry for all file types.

    With 64-bit Windows 10, that sometimes doesn’t work… not because Notepad++ or its installer is doing anything wrong, but because in some configurations of Windows, the OS is starting to move away from always honoring that old-style association, preferring instead to use it’s “OpenWith” list.

    In another post from last month (linked here), I pointed another user to look for a bad setting in HKCU\Software\Classes\Applications\notepad++.exe and/or HKLM\Software\Classes\Applications\Notepad++.exe – one or both of those may have accidentally gotten set to %ProgramFiles(x86)%\Notepad++\notepad++.exe instead of %ProgramFiles%\Notepad++\notepad++.exe, in which case Windows won’t allow “Open With” to get assigned to Notepad++. It may be in certain circumstances that the OpenWith confusion makes the edit-with-notepad++ global entry not work… I haven’t experimented with that.


Log in to reply