GEDCOM file extension (.ged)



  • Version 7.8.7 fixed new style save dialog by selecting right file filter and adding extension automatically.

    But when I open a GEDCOM file (.ged), edit and save it, Notepad++ wants to automatically save it as a text file, so I get a .ged.txt file.

    Is it possible to add .ged to the extension list so that it is automatically recognized as .ged, or else disable the automatic extension addition?



  • @TheDutchJewel

    This appears to be a regression due to the new “Fix new style save dialog by selecting right file filter and adding extension automatically.”

    Workaround
    When saving a file type that does not have an extension in the “Save As Type” box of the “Save As” dialogue, one has to manually select “All types (.)” in order for the “File name” with non-available extension to be saved as filename.non-available-ext.

    Description of the Issue
    Open a new file in Notepad++ and type some text. File=>Save As…, the “File name” in the “Save As” dialogue shows as “new 1.txt” and the “Save As Type” is “Normal text file (.txt)”. Rename in the “File name” text box of the “Save As” dialogue to “mygedcomfile.ged” and press “Save” button. File is saved as “mygedcomfile.ged.txt”. It should be “mygedcomfile.ged” without the additional “.txt” extension.

    Steps to Reproduce the Issue

    1. Open a new file in Notepad++ and type some text.
    2. File=>Save As…
    3. Change the “File name” in the “Save As” dialogue to “mygedcomfile.ged”
    4. Press “Save” button
    5. File is actually saved as “mygedcomfile.ged.txt”

    Expected Behavior
    File is save only as “mygedcomfile.ged”

    Actual Behavior
    File is actually save as “mygedcomfile.ged.txt”

    Notepad++ v7.8.7 (64-bit)
    Build time : Jun 5 2020 - 02:38:56
    Path : C:\usr\bin\npp64\notepad++.exe
    Admin mode : OFF
    Local Conf mode : ON
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 1809
    OS Build : 17763.1217
    Current ANSI codepage : 1252
    Plugins : AnalysePlugin.dll AutoSave.dll BetterMultiSelection.dll ChangedLines.dll CodeAlignmentNpp.dll ColumnTools.dll ComparePlugin.dll CsvQuery.dll CustomizeToolbar.dll DoxyIt.dll DSpellCheck.dll Explorer.dll GitSCM.dll JSMinNPP.dll NppConsole.dll NppConverter.dll NppEventExec.dll NppExec.dll NppExport.dll NppFTP.dll NppMarkdownPanel.dll NppMenuSearch.dll Python Indent.dll QuickText.dll SpeechPlugin.dll SurroundSelection.dll TagLEET.dll XMLTools.dll ZoomDisabler.dll

    Open issue: 8398

    Cheers.



  • @TheDutchJewel

    a workaround might be to define an UDL for *.ged files.
    Another, not tested, way might be to use the gedcom lexer plugin.



  • Thanks for the issue description and for the workaround.

    As a workaround, I save those .ged files in quotes (like “filename.ged”), but it would be nice if the problem is definitively resolved.



  • @TheDutchJewel

    This may not actually be a regression or bug. See here:

    https://community.notepad-plus-plus.org/topic/19529/notepad-v7-8-7-released/19

    Conclusion: Notepad++ Save As (and similar) let you keep the typed extension if the extension is listed in keys of HKCR in the registry

    Cheers.



  • I cannot reproduce the bug, could you provide me step by step instruction to reproduce it?



  • @donho

    Steps to Reproduce the Issue

    1. Open a new file in Notepad++ and type some text.
    2. File=>Save As…
    3. Change the “File name” in the “Save As” dialogue to “mygedcomfile.ged”
    4. Press “Save” button
    5. File is actually saved as “mygedcomfile.ged.txt”

    Expected Behavior
    File is save only as “mygedcomfile.ged”.

    Further testing by @PeterJones indicates that any extension selected that does not have an HKEY classes entry in the registry may produce this. See more detailed description at

    https://community.notepad-plus-plus.org/topic/19529/notepad-v7-8-7-released/19

    Cheers.



  • @Michael-Vincent Thank you for your instructions.

    It’s not bug for me though it’s quite annoying in some circumstance.
    To avoid this result, choose *.* filter before saving.
    I just checked the old style save dialog, the same behaviour happened as well.



  • @donho said in GEDCOM file extension (.ged):

    It’s not bug for me

    (also reference: https://community.notepad-plus-plus.org/topic/19529/notepad-v7-8-7-released/27)

    I tend to agree now that @PeterJones has showed us the registry HKCR and file extension experiment and I get the same behavior when saving with Windows standard plain old boring notepad.exe. This appears to be Windows default behavior, not a Notepad++ “bug”.

    However, there is some discussion on the issue I opened prior to fully understanding @PeterJones troubleshooting and explanation. You may want to close that?

    Thanks for Notepad++! - and sorry about the premature bug report.

    Cheers.


Log in to reply