Function List tab stops



  • I’m using a development version of 7.8.9 because I like some of the features:

    The latter I have working for Function List so when I’m in a document, I press my defined shortcut mapper key chord and BAM I’m in the Function List window! It’s great, but I’ve noticed that navigating in the Function List window doesn’t “respect” the Tab key.

    For example, I can scroll up and down and press enter and then the document shifts to that function and the cursor is placed in the Scintilla edit window - great. But when in the Function List if I want to filter by name, I have a text box to do so, but pressing Tab from the Function List list view doesn’t move the cursor to the search window:

    05102764-d467-4baa-92e8-55007d0e0f80-image.png

    I tried on the official 7.8.9 and same functionality as well as older versions - not sure this ever “worked”. I think the change needs to happen here. I normally put this in an RC file and just add Tab stops but this search edit control is in a menu so not sure how to C++ code this. Anyone know how heavy a lift this is?

    I submitted a feature request, but seems to have not gotten any traction.

    Cheers



  • @Michael-Vincent

    What about adding a WS_TABSTOP here?

    Sorry, I can’t test at the moment, because I’ve updated my community
    edition and now I get, as usual after an update, a bunch of errors telling
    me that nothing is defined anymore.



  • @Ekopalypse

    I wonder if it’s that easy … is so it’d be brilliant! I can’t test either as I’ve never been able to get dependencies to align and compiler tags right to compile N++ for myself. If that works for sure, I wonder if a pull request would have better chance making it in than my feature request.

    Cheers.



  • @Michael-Vincent

    Afaik, PRs without Issues\FR are ignored and closed.



  • @Ekopalypse said in Function List tab stops:

    What about adding a WS_TABSTOP here?

    I was able to try that and get it to compile! Sadly, it did not work. Seems to be a bit more complicated.

    Cheers.


Log in to reply