Setting File Associations



  • (Running NotePad++ ver. 7.8.8 under Windows 10 Enterprise ver. 1809 build 17763.1457)
    Cannot select File Associations under “Settings”. They are all greyed out.
    I closed the app and then right clicked it and ran it under “Run As Administrator”.
    Still will not let me change the File Associations to .TXT.
    Let me know what else I can try.

    Thank you.



  • @RLN88360 ,

    Are you sure it actually ran as admin when you chose Run As Administrator? Does the title bar say [Administrator] at the end? Does the ? menu, Debug Info say Admin mode : ON? If not, then you didn’t actually run as administrator.

    If it does say that you are admin, can you give us a screenshot of your Preferences > File Association, because in Admin mode, mine looks right:
    77526d4b-d16e-4e6c-a92b-de58b10a9ca9-image.png

    When I am normal permissions, my File Association settings show:

    b0db8230-24bc-4039-bbee-d89a8d930169-image.png

    My screenshots added Debug Info on top, to make it clear whether I was in Admin mode or not.

    Or, are you saying that with Admin, you look like the first screen, but it still doesn’t change anything?



  • The mistake I made was copying just the icon to the desktop for ease of use. Wrong thing to do.
    I am running it from the original folder where it was installed and it is fine now. File Associations were set up correctly. This issue can be closed.


Log in to reply