Help selected lines are blacked out How to fix ?



  • Hello & Thanks ;
    Help selected lines are blacked out How to fix ?
    I have GLobalOverrides set with Foreground Black and Background White .
    Which is all good until I select something , then the selected line is all blacked out . How can I fix this ?
    Thanks for your Help…



  • @vmars-vernon ,

    That sounds like you have language: Global Styles > Style: Selected text colours set to background = black, so that seting when combined with a global foreground color of black will make the text all black. So “to fix” the problem (for an unrecommended definition of “to fix”), just change the Selected text colours background so that it’s not black.

    But that’s only the symptom of something else: you shouldn’t normally need the Global Override, because settng the Default Style is usually sufficient for defining the normal plaintext color.

    So one guess of what’s going wrong for you is that at some point you changed the theme (the top dropdown in the style configurator dialog), and are now trying to “undo” that theme by setting Global Override color – if that’s the case, the better thing to do would be to change back to the Default (stylers.xml) theme.

    But that’s just a guess; I should really just ask straight out: What are you trying to accomplish with setting and enabling the Global Overrides colors? Do you really want all text to be black, no matter what syntax highlighting is going on? Because that gets rid of most of the context information that the language stylers provide for you, and will sometimes not play well with some of the color settings that don’t get overridden by that.



  • [because settng the Default Style is usually sufficient for defining the normal plaintext color.]
    Thanks


Log in to reply