Error in comments.



  • I created my own language, but the comments don’t work properly:
    d0a9f341-2117-4191-aa16-7390933e4055-image.png
    26088820-bb57-4ae4-bffc-299b73264c86-image.png
    What do I have to change to make it appear correctly?

    Greetings, Matthias



  • @Matthias-Steiner ,

    You haven’t shown us enough about your UDL, because if I have just the sections you showed us, I get
    1dee150b-c8fa-494e-9e57-3a58125a714c-image.png
    …that is, the comments all properly highlight.

    My guess is that your comments are actually nested in something else (a delimiter, or a folding section, or similar), but that the Styler for that element doesn’t allow nesting of comments.
    aed1f745-9218-4e8c-880f-a36a135f131f-image.png

    Without your complete UDL definition, I cannot tell you more specifically which element needs to enable the nesting for comments/block-comments. … But hopefully, this is enough for you to figure it out on your own, or you will share more info with us. Good luck



  • 253/5000
    Ok, I did, but to no avail.
    I’ve now realized that it must have something to do with the Delimiters. Because if I enter “#” as the end, it works. But that would not be the right way, as that is certainly not always the end …
    729e942d-2fba-4a82-a767-fd49f112df9c-image.png



  • @Matthias-Steiner

    Delimiter work best if they are defined with start/end tags.
    If other parts are within a delimiter try playing with nesting (available via styler button) to see if this solves your issues.


Log in to reply