How to disable "smooth font"?



  • Hi!
    I just updated Notepad++ to the latest version. I saw immediately that all text now was blurry. How do I disable this annoying “smooth font” you have introduced?
    Thanks in advance.



  • Hello H2SO4JB,

    If you downloaded the very last version : v6.8 ( Just hit the F1 key to verify ) :

    • Open the Preferences dialog ( Settings - Preferences… )

    • Select the Editing sub-menu

    • On the right bottom corner, uncheck the Enable smooth font option

    Et voilà !

    Best Regards

    guy038

    P.S. :

    As I currently use N++, on a old WinXP configuration, I don’t know exactly, but, may be, you’ll need to start N++ as an administrateur, to enable the changes, with an W7/W8 configuration ?



  • I see. I had version 6.7.9.2, which was the latest version when I check for updates.
    And in this version this option was not available. But I have now installed V6.8, and
    have found this option. Thanks! :-)



  • Hello,

    I tried Notepad++ 6.8 in a Windows 7 x64 Virtual Machine to see what the new font looks like.
    For some reason the “Enable smooth font” option doesn’t work properly and smooth font is always enabled.
    There isn’t any visual difference when the option is checked or unchecked (even after restart).
    The Source Code Pro font looks very blurry with smoothing so that’s really unacceptable for me.
    I changed the font to Courier New and the “Enable smooth font” option doesn’t affect its look as well.

    Regards.



  • I experimented some more and found that the Source Code Pro .ttf files from this archive look much better:
    https://github.com/google/fonts/archive/master.zip

    However there are two issues:

    • Even if I install the .ttf font, Notepad++ still uses its own version SourceCodePro-Regular.otf
    • If I rename SourceCodePro-Regular.otf then it uses the .ttf version, but the Cyrillic alphabet is not available

    If I change the font in Notepad to Source Code Pro I can write in Cyrillic without problems. But in Notepad++ it shows some strange characters.
    With the .otf version that comes with Notepad++ there isn’t a problem with the Cyrillic text, but it looks very blurred and it’s hard to read.



  • Hi Cyril,

    Could you try this improved version regarding the font:
    https://notepad-plus-plus.org/temp/npp.7z
    unzip it into a new created folder, reboot the system (in order to process the test properly), then launch notepad++.exe.

    Please let me know if your issues are solved.



  • Hi Don,

    I tried this improved version and I can only say that it looks great!
    The font looks sharp and the Cyrillic text is displayed properly.

    Thanks for creating such a great editor!

    Regards,
    Cyril



  • Hi Donho,
    I have the same problem as Cyril but I can’t get tje npp.7z file.
    Can you help me ?
    Thank you


Log in to reply