Restore right margin word wrap as in 7.8.5



  • @rd4gh said in Restore right margin word wrap as in 7.8.5:

    I will probably roll back to 7.8.5

    Not necessary, you should try my workaround using NppExec script plugin given in the other thread.



  • @rd4gh said:

    I’ve been “suffering” without this for some time, but finally thought I’d ask if it could be restored as an option.

    lines that I want to be only 80 characters

    So here’s a method that requires nothing special – so I won’t call it a workaround – except for a change to a Notepad++ setting:

    Tick the Background mode box:

    c760f992-ef18-45bd-84e3-8052eff154d9-image.png

    After doing that, you’ll notice that Ctrl+i again works to split lines at your set column value; 80 in my screenshot.

    You may dislike the coloring used for the text background at column 80+, however it is a simple matter to adjust the coloring to a really light grey (assumes default white text background color/theme selected) so that the intrusion is minimal.

    End the “suffering”. :-)



  • Hello, @rd4gh, @alan-kilborn and All,

    You do not need, at all, to stay with the Background mode set !!

    The best method for using the Ctrl + I functionality and splitting text at column N, is :

    • Run Preferences... > Margins/Border/Edge > Vertical Edge Settings

    • Wipe out all the existing column markers, if any

    • Type in the column marker N, ONLY ( generally the 80 value )

    • Tick the Background mode option

    • Immediately un-tick the Background mode option ( Important )

    • Re-enter all your previous column markers

    • Click on the Close button

    =>

    • Even though you can see all your column markers, again, Notepad++ remembers that the position to split text, with the Ctrl + I option, is column N

    • This behavior is kept, even if you use the Ctrl + I option on new opened files, on closed and re-opened files and after switching tabs !

    • The only way to reset this splitting behavior, on column N, is to close the current N++ session and restart N++ ;-))

    Best Regards,

    guy038



  • @guy038 said in Restore right margin word wrap as in 7.8.5:

    The only way to reset this splitting behavior, on column N, is to close the current N++ session and restart N++ ;-))

    With the statement I’ve quoted, are you saying that restarting N++ will prevent Split Lines from working, after setting it up as you describe in the workaround?

    If so, that’s hardly viable, as nobody would want to do that setup after every restart, just to use the split-lines feature.



  • Hello @rd4gh, @alan-kilborn and All,

    Unfortunately…yes :-((

    Once you re-start Notepad++, you’ll see the possible vertical edges, previously defined, but, again, the Ctrl + I operation will simply split all lines of current file to the right margin of the present editor window, this is the default behavior !


    However, an easy other work-around is to zoom in, with Ctrl + Nummpad +, in order that the column 80 is closed to the right side of the editor window. For instance, using the Consolas monospaced font, after six hits on Ctrl + Nummpad +, the column 82 is near the right of the N++ window !

    Best Regards,

    guy038



  • @guy038 said in Restore right margin word wrap as in 7.8.5:

    an easy other work-around is to zoom in

    Yes, that works, but it is probably not satisfying to the OP. :-)



  • Hello, @rd4gh, @alan-kilborn and All,

    A third solution could be to install, in addition to the latest release, a portable N++ v.7.8.5 version, once and for all, and set the vertical edge to column 80

    The OP could even download the Mini-portable (7z) archive of N++ v7.8.5 !

    Cheers,

    guy038



  • @guy038 said in Restore right margin word wrap as in 7.8.5:

    A third solution could be to install, in addition to the latest release, a portable N++ v.7.8.5 version, once and for all, and set the vertical edge to column 80

    Using an old version that makes you happy is always a choice! :-)



  • I noticed a difference in the behavior of the Split Lines (Ctrl+i) behavior – when using the vertical edge’s background mode, of course – depending upon whether or not the Use DirectWrite preference is enabled/disabled.

    Before invoking Ctrl+i things appear like this:

    Imgur

    After invoking:

    • First trial, here is a (more-desired) result when Use DirectWrite is unticked/disabled:
      Imgur

    • Second trial, a (less-desired) result when Use DirectWrite is ticked/enabled:
      Imgur

    Note that in the “first” case, the word under does not get moved to the following line, but in the “second” case, it does.
    Correct behavior would be to keep “under” with line 8.
    [Also: Purists might feel that the the following “under” should also be kept with line 8.]

    Conditions: Single selection on line 8 when invoking Ctrl+i to split the line, (single) vertical edge specified to be 60, file: license.txt from N++ distro.

    The moral of the story: DirectWrite impacts the splitting of lines, and there are probably still more areas where DirectWrite (in general a good thing) adversely impacts N++ features.



  • @Alan-Kilborn

    Yes, I have seen this effect, too. It seems like character spacing is slightly smaller when DirectWrite rendering is activated. I tested some minutes ago with Npp v7.9.1 and saw that with DirectWrite the Scintilla window showed 85 characters and with standard rendering it showed 83 characters. In pixels the difference was 17 px.

    Here are screen shots from my test, captured with a screen magnifier:

    ca999e07-59f7-4bbe-a633-d6f651f7dfea-grafik.png

    561a4be7-53af-4fd8-b457-1b661f0b2804-grafik.png

    Unfortunately this issue causes the Horizontal Ruler plugin to draw an inaccurate ruler - Scintilla’s edge line is drawn at the correct position (after column 80) but the plugin’s ruler shows column number 88 at this postion:

    bf029625-d4bf-46a9-ac17-0b7af81c3344-grafik.png


Log in to reply