File Switcher not responding



  • Hi - I’ve been using the File Switcher plugin over the last few months and love it. For some reason, after updating NP++, I’m now unable to get File Switcher working. I can either go directly into it or with the shortcut (CTL+SHIFT+O) and it just hangs. Here are my specs:
    Notepad++ v7.9.2 (32-bit)
    Build time : Dec 31 2020 - 03:58:36
    Path : C:\Program Files (x86)\Notepad++\notepad++.exe
    Admin mode : OFF
    Local Conf mode : OFF
    OS Name : Windows 10 Enterprise (64-bit)
    OS Version : 2004
    OS Build : 19041.804
    Current ANSI codepage : 1252
    Plugins : Explorer.dll FileSwitcher.dll mimeTools.dll NppConverter.dll NppExport.dll

    Thanks!



  • @Brian-Eliason

    I don’t know anything about the File Switcher plugin; in fact I never heard about it until I read your posting.

    Perhaps try the Navigate To plugin as an alternate? Maybe you’ll like it.



  • @Brian-Eliason ,

    Sorry, Brian, I cannot replicate your results.

    I pulled up v7.9.2 32-bit portable, and installed the File Switcher plugin (1.0.3) from Plugins Admin. I opened a few files, and used Plugins > File Switcher and tried the various menu entries (previous, next, options, about, and show); I accessed the Show File Switcher through both the menu and the Ctrl+Shift+O shortcut.

    4aea1cd9-13e8-4b51-b378-b6e1afaffafc-image.png

    I had no difficulty using that to filter based on the filename.

    4bfbbcd3-fd98-4966-ae84-f14cbee6690e-image.png

    Maybe it doesn’t play well with the Explorer plugin? Nope, I installed that, too, and I was still able to access File Switcher without hangs or crashes.

    Maybe your %AppData%\Notepad++\Plugins\Config\fileswitcher.ini is corrupt – I had another plugin’s ini become all NULL bytes, and when I deleted it, everything started working again (and it re-created its ini) – so maybe something similar has happened to you.

    If that doesn’t work, you might want to download a fresh portable edition, unzip it to a folder on your desktop, and try installing the plugin in that version (if that works, then maybe something is wrong with your normal NPP installation). Or maybe uninstall the File Switcher plugin and re-install it.



  • @Alan-Kilborn said in File Switcher not responding:

    I don’t know anything about the File Switcher plugin; in fact I never heard about it until I read your posting.

    I hadn’t either… but I saw it was in the 32bit Plugins Admin list and it was by @bruderstein , so it’s not like it’s from an untrusted source. (Just, unfortunately, unmaintained.)



  • @PeterJones - It worked! I shutdown NPP, deleted the ini reference, restarted and we’re back in business. Thanks for your (and others) help!


Log in to reply